Jump to content
Yury

Black image in Capture NX-D after exporting in Affinity Photo

Recommended Posts

Hello,

I'm experiencing a strange problem - some jpeg files turn to plane black after exporting in Affinity Photo (AP). Let me explain.
First I saw it on v1.4. I could even see the problem using mac preview, images would be simply black. I even stopped using AP for that reason. In AP v1.5.2 things got better, mac preview shows images. However my workflow includes Nikon Capture NX-D. And here I experience the issue again. So, Nikon software can't open some files, to be more precise, it opens but I see nothing but black.
It happens randomly and only to files exported or edited and saved by AP. I never had that issue with files exported from other photo editors. Attached is a file which I adjusted in AP and re-saved, and since then I'm not able to see the image in Nikon software. Screenshot from NX-D is also attached. 
I really like the AP latest updates (macros, batch) and would like to use it, but this little thing with export stops me at the moment. I also have tried the beta version (1.6.4 beta4) with the same result, I mean I opened the problematic file and reexported it, the same result in nikon software. Perhaps I'm doing something wrong while exporting the images, but it only happens to Affinity Photo and it happens randomly.
Could you please help me with this?

26.jpg

Screen Shot 2017-08-04 at 22.49.23.png

Share this post


Link to post
Share on other sites

Hi MEB,
thanks for your reply.
I tested saving the file with unchecked Embed Metadata. Issue still remains - black image in Capture NX-D. Also I tested the problematic photo with Nikon Capture NX-2 and the result is a bit different. After file is opened the image is filled with black and there is a message  Updating image.  After some time (several seconds) the real image appears.  However if I try to apply Unsharp Mask the image turns to black. It happens to both files with Metadata and without. Exporting file with Capture NX-2 does not solve the problem.

Share this post


Link to post
Share on other sites

Would you please advise as to when this will be fixed? Issue remains with AP 1.6.6 and Nikon ViewXN-i 1.2.10.

 

Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.