Jump to content
befehr

Cropping issue in AP within Apple Photos

Recommended Posts

Editing a photo through the Apple Photos extension, cropping in the develop module is not cropping where indicated. See attached images.

Cropping works OK in Edit module

Screen Shot 2017-08-01 at 4.19.50 PM.png

Screen Shot 2017-08-01 at 4.19.56 PM.png

Share this post


Link to post
Share on other sites

Hi befehr,
Unfortunately I'm unable to reproduce this. Would you be able to upload the RAW file used in your screenshot please? Also how are you applying the crop, what did you do between the first and second screenshot?

Share this post


Link to post
Share on other sites

I think I can assist with reproducing this - was about to log it myself.

 

I get this same issue as Befehr above when using Apple Core Image Raw as the RAW engine. I'm getting it opening a file directly in Affinity.

 

If you rotate and then crop, the crop doesn't honor what you select. You end up with an offset image with the white/grey boxes as above.

 

I don't get the same issue if using Serif Labs RAW engine.

 

I'd really like to be able to use the Apple Core Image RAW engine as it seems to handle highlights a little better for my .CR2 Canon RAW files.

 

UPDATE Aug 17: Note the problem only seems to be in the Develop Persona, not the Photo Persona, so that is a workaround. Would be great in Develop though.

 

Please let me know if you cannot reproduce and I'll get you more details.

 

OSX Sierra, MBp 15" Retina, Canon G15 .CR2 file.

 

Craig

 

 

Edited by Craig Comerford
UPDATE to note that the issue only occurs in the Develop persona, using the Photo Persona to crop/rotate seems to be a workaround

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×