Jump to content
hawk

Layer multi-selections

Recommended Posts

When you command+click or shift+click to select multiple layers, moving upward in a long list of layers, the list always jumps back to the bottom-most selected layer. This is not helpful.

Related suggestion: shift+clicking to select a range of layers starting at the last command+clicked layer shouldn't deselect previously command+clicked layers. It should work like selecting table cells in Pages does, as it allows more control. Pixelmator also does this correctly.


AD+AP, Mac 10.9, kbd & mouse, casual user since 2014

Share this post


Link to post
Share on other sites

Thank you very much for responding to my post!

 

No, that doesn't demonstrate what I mean. That example is correct and the behavior in that specific situation wouldn't be affected by my suggestion.

My first problem (the bug) is that when you select multiple layers that are more than one layer studio height apart, i.e. they don't all fit on the screen at once, it instantly scrolls down to the first selected layer if it isn't visible.

My suggestion is to allow multiple range selections with gaps in between, by using both ⌘+click and ⇧+click. Currently when you use ⇧+click, it causes all other layers that are not in that range to be deselected.

This video shows both of these issues:

For comparison, here's the same scenario played out in Pixelmator, which shows the behavior I'm suggesting:

 


AD+AP, Mac 10.9, kbd & mouse, casual user since 2014

Share this post


Link to post
Share on other sites

Hey hawk,

 

That video was perfect - thanks. I see your improvement suggestion so I'll pass that on. I can't reproduce the jumping back to the initial layer. What OS X are you using? I've tried it on High Sierra, Sierra and Yosemite. I'm just trying to find an El Capitan machine... 

Share this post


Link to post
Share on other sites

Thanks! :) I'm using 10.9.5 but I don't think that's the cause. I believe it's a bug with the UI preference 'Show Selection in Layers Panel'. If I turn that off it doesn't happen.


AD+AP, Mac 10.9, kbd & mouse, casual user since 2014

Share this post


Link to post
Share on other sites
15 hours ago, hawk said:

I believe it's a bug with the UI preference 'Show Selection in Layers Panel'. If I turn that off it doesn't happen.

Hah! Yes, you're right—thanks! I'll add that to my log. It does look wrong to me.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×