Jump to content
MattP

Affinity Designer Customer Beta (1.6 - Beta 4)

Recommended Posts

Status: Beta Release

Purpose: New features, fixes

Requirements: Purchased Affinity Designer

Mac App Store: Not Submitted

Download: Here

 

This beta version represents a substantial change to our codebase and as much as we have tried to ensure the quality of the code, it should be considered to be not suitable for production use. This means that you should not attempt to use it for commercial purposes or for any other activity that may be adversely affected by the application failing. In addition it is definitely worth noting that files created in Affinity 1.6 may not open in 1.5 so always make a copy of your important documents before opening them in 1.6 to ensure you do not accidentally overwrite them and are unable to open them in your 1.5 version.

 

To use this beta, simply download the file from the link given above and double-click on the file to open the installer. Follow the instructions to install the beta version. The beta sits alongside the Mac App Store version and will not interfere with it.

 

Fixes/Improvements:

  • Further Light UI improvements
  • Added 'Lock'/'Unlock'/'Unlock All' and 'Hide'/'Show'/'Show All' menu items with shortcuts
  • Fixed many symbol bugs and crashes
  • Fix for PDF/EPS export of large rasterised areas causing visible gaps on occasions
  • Fix for Gray8 format documents failing to draw as intended
  • Fix for crash when copying artboards that contained symbols with text inside
  • Fix for crash when moving compound objects inside constrained containers
  • Fix for slices and guides not drawing correctly sometimes after a pan/zoom
  • Custom pixel brush wet edges
  • Fixed inability to hold shift and click in brush tools to create a straight line
  • Fixed inability to load Procreate PSD files
  • Localisation improvements

 

* Please note that macOS Sierra has a bug in Metal with AMD graphics cards which means colour correction will not function perfectly, hence why it is disabled by default. If you have an Intel or Nvidia card then feel free to try it. This bug was fixed in High Sierra so all cards should work as expected  :)

Share this post


Link to post
Share on other sites

Hi, i've noticed, in both AD and AP, that the right hand side studio panels make the apps crash if you want to re-arange them. When dragging out an individual studio panel it's all fine, but as soon as i want to drag out the last remaining studio panel, (or if you drag out the full panel set, i.e. Layers, Effects, Styles in one go) there's crash. This happens consistently.

Share this post


Link to post
Share on other sites
9 hours ago, MattP said:

 

  • Added 'Lock'/'Unlock'/'Unlock All' and 'Hide'/'Show'/'Show All' menu items with shortcut

Matt,

 

Thanks for all the hard work! I love the "Unlock All" and the "Show/Show All" but for some reason I can't find the "Hide"? Was that a mistype or am I looking in the wrong place?

 

Hokusai

Share this post


Link to post
Share on other sites

Matt,

 

I think I understand now. You have two "Show All" options but one of them is actually "Hide"! Thanks a million for adding that! I'm so happy to be able to hide things and show all with a shortcut!

 

Hokusai

Share this post


Link to post
Share on other sites

Hey Hokusai, I assigned a few shortcuts to these and its working well.

 

Now we just need Matt to implement that "lock all but selected" and "hide all but selected" or "isolate" and we'll be in business ;-) 

 

Sorry Matt, ... at least I didn't bring it up in your post. ;-)

Share this post


Link to post
Share on other sites

Matt. The Reset Fonts button in Preferences seems still not to work. If I activate a new font and go to reset, that font remains unavailable within AD. Resetting fonts in AD used to make any newly activated fonts available without the need to restart the app.

Share this post


Link to post
Share on other sites

Hello, 

I would like to know if you plan to add in this version (1.6) : selection by type. 

I ask because you feature like : 

  • Added 'Lock'/'Unlock'/'Unlock All' and 'Hide'/'Show'/'Show All' menu items with shortcuts

Thanks  


Clém !

Share this post


Link to post
Share on other sites
2 hours ago, ianrobertdouglas said:

Matt. The Reset Fonts button in Preferences seems still not to work. If I activate a new font and go to reset, that font remains unavailable within AD. Resetting fonts in AD used to make any newly activated fonts available without the need to restart the app.

 

I'm not sure about the resetting thing, but in AD on Windows I've never needed to restart the app to make it 'see' newly activated fonts. I do, however, need to close and reopen any affected documents.

 


Alfred online2long.gif
Affinity Designer 1.6.5.123 • Affinity Photo 1.6.5.123 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.6.11.85 • Affinity Designer for iPad 1.6.4.45 • iOS 12.1.4 (iPad Air 2)

Share this post


Link to post
Share on other sites

Matt, I may be a little slow this morning but I am having trouble figuring out the: "Added 'Lock'/'Unlock'/'Unlock All' and 'Hide'/'Show'/'Show All' menu items with shortcuts".

 

The Lock and Unlock works as expected, any selected layers are locked or unlocked with this command.

Unlock All I thought would unlock all layers in the drawing.  But it seems to be only to unlock the selected layers.  What is the difference between Unlock and Unlock All?

The first Show All seems to shut off the visibility of the selected layer.  So I would guess this is really a Hide command.

The Show acts as expected with turning on the visibility of only all selected layers.

The (second) Show All turns on the visibility of only the selected layers.  What is the difference between Show and Show All?

 

Isn't the idea of the "All" that it will affect layers selected and not selected?  If not what is the effect of All?

 

Thanks.

Mike


iMac (27-inch, Late 2009) with macOS Sierra

Share this post


Link to post
Share on other sites
11 minutes ago, Gear maker said:

Matt, I may be a little slow this morning but I am having trouble figuring out the: "Added 'Lock'/'Unlock'/'Unlock All' and 'Hide'/'Show'/'Show All' menu items with shortcuts".

 

The Lock and Unlock works as expected, any selected layers are locked or unlocked with this command.

Unlock All I thought would unlock all layers in the drawing.  But it seems to be only to unlock the selected layers.  What is the difference between Unlock and Unlock All?

The first Show All seems to shut off the visibility of the selected layer.  So I would guess this is really a Hide command.

The Show acts as expected with turning on the visibility of only all selected layers.

The (second) Show All turns on the visibility of only the selected layers.  What is the difference between Show and Show All?

 

Isn't the idea of the "All" that it will affect layers selected and not selected?  If not what is the effect of All?

 

Thanks.

Mike

Take a look at the Beta 3 thread where I describe how they work in detail :)

Share this post


Link to post
Share on other sites
2 hours ago, MattP said:

Take a look at the Beta 3 thread where I describe how they work in detail :)

Ah I see.  Thanks for leading me to the instructions.


iMac (27-inch, Late 2009) with macOS Sierra

Share this post


Link to post
Share on other sites

Hey guys since you don't have Publisher out yet, and honestly InDesign is not up to the job - rendering issues with vector files and buggy GPU issues in screen rendering - you're it.  I'm working on a design project using multiple artboards.  I was a little afraid of this at first but Designer is fast, smooth and there is no lag even when I have hundreds of layers in embedded (and directly editable!) objects and dozens of these objects.  Wow.  And I can create text styles just like image styles.

 

Only thing that is really hurting and missing is that I have no way of using guides throughout the artboards, and "paste in place" (InDesign feature) is sorely missing.  This means I am sure to make some alignment errors but I'm developing some workarounds.  Any temporary fixes or tips to help out in the meanwhile, or future developments in this category.  Yes, I know, wait for Publisher, but I can't...

 

Lastly, is Beta 4 more stable now or keep with 1.5 for my project?

Share this post


Link to post
Share on other sites

I too am interested in the option to hide/show and lock/unlock all, so I took another look at the post Matt mentioned. It works very well, but I noticed that there are two "Show All" options in the Layer menu. I think the first one is meant to be "Hide All" since that is the option it performs. The second does as it should.


The website is still a work in progress. The "Comics" and "Shop" sections are not yet ready. Feel free to connect with me and let me know what you like or what can be improved. You can contact me here, on my contact page, YouTube channel, or Twitter account. Thanks and have a great day!

Share this post


Link to post
Share on other sites
12 minutes ago, Bri-Toon said:

I too am interested in the option to hide/show and lock/unlock all, so I took another look at the post Matt mentioned. It works very well, but I noticed that there are two "Show All" options in the Layer menu. I think the first one is meant to be "Hide All" since that is the option it performs. The second does as it should.

I must've messed something up - here's what I'm seeing:

 

597de6a5e4c6f_ScreenShot2017-07-30at15_00_27.png.9ea89fbc0fa39b16da2146144db394f5.png

Share this post


Link to post
Share on other sites

Hmm... that's strange. Here is what I'm getting. (Don't mind my dog barking in the background.)

 

 

20170730100331.mov


The website is still a work in progress. The "Comics" and "Shop" sections are not yet ready. Feel free to connect with me and let me know what you like or what can be improved. You can contact me here, on my contact page, YouTube channel, or Twitter account. Thanks and have a great day!

Share this post


Link to post
Share on other sites

Oh, I found a nasty little bug in the Beta (as well as in the App Store version) today, though I am not sure if it is apready reported. I believe my video is quite self-explaining. Create some objects and clip them to a parent shape. Nest an adjustment layer to the parent and toggle “Lock Children,” such that the children are finally locked. Then move the parent shape around. Have a look at the result. :(

 

Lock-Children-Adjustment-Layers-Bug.mov

Share this post


Link to post
Share on other sites
7 hours ago, A_B_C said:

That’s a localisation error in the U.S. English version … B|

 

That is a really good catch and I never would've guessed, but it looks like my language was set to Default while English (United States) is a separate option, but I'm not entirely sure what the difference is.


The website is still a work in progress. The "Comics" and "Shop" sections are not yet ready. Feel free to connect with me and let me know what you like or what can be improved. You can contact me here, on my contact page, YouTube channel, or Twitter account. Thanks and have a great day!

Share this post


Link to post
Share on other sites

Hi Tekikou, I'm guessing you're just falling foul of an export bug that was accidentally added in this Beta 4. I'll try to build again tomorrow and upload a new version that doesn't have this error. Sorry... :(

Share this post


Link to post
Share on other sites

Hello again,

I may have caught something else. There seems to be a problem when pasting inside of objects which have a compound path. I Alt clicked on the subtract boolean button, and that part worked. But now, I cannot paste objects inside it for a shading effect. Please see the attachment.

 

 

20170731123525.mov


The website is still a work in progress. The "Comics" and "Shop" sections are not yet ready. Feel free to connect with me and let me know what you like or what can be improved. You can contact me here, on my contact page, YouTube channel, or Twitter account. Thanks and have a great day!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×