Jump to content

Recommended Posts

Please can anyone tell me why two days ago I could access all my Affinity Designer files. Yesterday I get this message on all my files.

I have give access/permissions using File info on all of the files and folders. Also when I finally got one to open I had a black (not white) artboard.

I am so frustrated that I downloaded the trial version of Affinity Designer onto my laptop and worked to create my files again. I had NO PROBLEM with redesigning and saving these files. I then copied them onto my usb and tried opening new files on my main working imac. You guessed it Permissions denied. Have I a corrupt application and if so will they send me a new one without having to rebuy?

Has anyone had these problems, I like this program and would hate to have to go back to Illustrator.

 

John Elsegood

Screen Shot 2017-07-25 at 1.37.40 PM.png

Share this post


Link to post
Share on other sites

Hi John,

Have you recently installed a load of fonts into Fontbook? I believe there is an issue Apple Sandbox permissions issue that is caused by having too many fonts installed into Fontbook. Was there anything else you remember doing on your mac in those 2 days between your files working and not?

Share this post


Link to post
Share on other sites

I did load Suitcase Fusion 6 to change a type face. Strange ting now is that Suitcase will not verify any typefaces.
I can't open even my earliest designs in Affinity.
But loading the Trial onto another computer, I can open files that I can't open on my iMac.

I have run diagnostics and they all say there is no problem.

I think perhaps I will have to reinstall various programs.

Any thoughts.

Share this post


Link to post
Share on other sites

If I uninstall Affinity Designer from my system. Can I reinstall from Apple Apps as I have a paid version.

I can also reinstall Suitcase 6 which should give me no typefaces in the program. I am not sure about Font Book, perhaps I can clean up permissions from Library! But never tried that.

The Trial version yesterday worked perfectly on my laptop, but when I transferred files back same Permissions problem. At least I have not lost them.

I appreciate everyones help in this.

John

Share this post


Link to post
Share on other sites

:D Fixed. I used Time Machine to go back a month and changed over Suitcase 6. I changed Font Book to dump all but Standard fonts. Ran Disk Utility and Clean my Mac 3. Restarted and then put back my typeface I required. And it worked. Thanks to all.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.