Jump to content
Robert Cailliau

Toolbar disappears in Affinity Photo separated mode

Recommended Posts

Can anyone please tell me how I get the toolbar to show in separated mode in Affinity Photo?

I run:  macOS Sierra 10.12.5; macbook Pro13,3, intel i7, 2.9GHz, 16GB.  Two Cinema 30" displays (2560x1600 each), laptop's lid closed so its own screen is not used.

I have re-installed Affinity Photo etc. but in separated mode the toolbar disappears!

It drives me crazy to have to work in a single window.

Separated mode works well in Designer.

I suspect it may have to do with the screen coordinates at which the toolbar is drawn, i.e. it is probably off-screen somewhere, though it does not appear on the laptop's screen either if I open the lid or if I start Photo with the lid open.

Help!


Robert

(Affinity Designer—Affinity Photo—LiveCode—Mac OS X various)

Share this post


Link to post
Share on other sites

Hey Robert,

 

Unfortunately using the 'Reset Studio' option does not work in Separated Mode if the toolbars are appearing off-screen which is what I think is happening here. Your only option would be to close down the app and launch it with your ctrl key held down. Hold it until you see a dialog appear and click Clear. This should restore the position of the toolbar for you. 

Share this post


Link to post
Share on other sites

Worked! Thanks!

I confess some of my own programs showed this problem of having windows unreachable off-screen after attaching or detaching external displays.  They have been changed so that at launch they move any window whose top-left corner happens not to be on a connected screen onto such a screen.

OK, an easy bug to correct then.

Thanks for the tip.

PS: it's not easy to launch with the control key down, as that brings up a contextual menu from which one has to choose "Open".


Robert

(Affinity Designer—Affinity Photo—LiveCode—Mac OS X various)

Share this post


Link to post
Share on other sites

Hey Robert,


I've passed your feedback on and put an improvement request in so there is an easier way to return the toolbars etc. without having to reset the app. 

Share this post


Link to post
Share on other sites

Hi everyone,

 

I just wanted to note that this problem still persists in the current version 1.6.7. Last week in the office, I worked in Separated Mode with an external monitor plugged into my Macbook. I am now at home and can't get the main toolbar and context toolbar back on screen because I think Affinity remembered their position on the external display (which I don't have at home). Well, I think I can bring them back tomorrow when I'll be at the office again. It's still annoying though, and with the many customisations I made, I don't want to clear my user defaults. Certainly there should be a more elegant way to handle this.

 

Cheers

kaffeeundsalz

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.