Jump to content
Jimmini

Dragging text path handles freezes application

Recommended Posts

In Affinity Designer 1.5.3.69, when dragging either the start or end handle of the text path in the attached file, while holding the CTRL key, the application slows down significantly and ultimately becomes unresponsive.

TextPathBug.afdesign

 

Edit: I mean these orange handles which define the text's range:

T3E32Au.png

Share this post


Link to post
Share on other sites

Sure. I'm running Windows 10 64-bit, Intel i5-7600, 16GB DDR4, NVIDIA GTX 1080 Ti.

CPU usage goes to about 40%. The same happens in Affinity Photo. It only happens when holding CTRL while dragging the handles. After dragging the handles using CTRL for a bit, it's even slow without pressing any modifier keys afterwards. The amount of time the application freezes depends on for how long I dragged the handles.

Share this post


Link to post
Share on other sites

Hi jimmini

 

Would you be able to quickly try this for me. Can your go to preference > performance and change renderer to WARP, This may be slightly slower overall, but it would like to see if it is more consitent and perhaps easier on the CPU

 

Cheers


Serif Europe Ltd - Check the latest news at www.affinity.serif.com

Share this post


Link to post
Share on other sites

Sadly still the same. I don't notice any difference.

The application is unusable for a few minutes, even when I manage to deselect the layer and switch tools. Even when the CPU usage drops to 0% again after some time, the application is *very* slow to use afterwards, whenever the document has to be rerendered (where CPU usage even goes to 100% on all four cores).

Changing font, font size, text alignment or transforming the shape doesn't make a difference either.

Share this post


Link to post
Share on other sites

Im having the same issue as Jimmini, When attempting to move the text parameters on a curve when holding the command button on a mac.

goes to 100% CPU and AD becomes unresponsive. Ive tried in a different user and same issue again.

 

Specs: Macbook Pro 2012, 2.3 GHz i7, 16GB RAM, NVIDIA GeForce GT 750M 2048 MB

 

Makers Mark - Henry.afdesign

Share this post


Link to post
Share on other sites
6 hours ago, JACKJACK1234 said:

Im having the same issue as Jimmini, When attempting to move the text parameters on a curve when holding the command button on a mac.

goes to 100% CPU and AD becomes unresponsive. Ive tried in a different user and same issue again.

 

Specs: Macbook Pro 2012, 2.3 GHz i7, 16GB RAM, NVIDIA GeForce GT 750M 2048 MB

 

Makers Mark - Henry.afdesign

It seems that Your file is very good AD killer ;)
I've never yet had such problem with AD, but with Your file my copy of AD is unusable and unresponsive.

My config is old a bit, but in most of the tasks is ok:
Xeon E5450 3GHz
8GB RAM (DDR2)
GT 730 2 GB
Windows 7 64bit


Windows 7 | Intel Xeon E5450 | GeForce GT 730 | 8 GB RAM

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.