Jump to content
billgatto

Affinity designer on windows 10 freezing

Recommended Posts

Hi, I use Affinity Designer on windows 10 for almost a year now, after using Corel Draw from version 2 to x7. I did change because I liked affinity right away and I decided to buy it and now I just use this one. However, there is a big problem working fine and the application is continually freezing for a few seconds even for simpler operations. It's frustrating to work so you lose a lot of time. Is there any solution? Thank you

Share this post


Link to post
Share on other sites

Hi Billgatto,

This is an issue I personally encountered on my home machine once, but after restarting the app it was fine and I've not been able to reproduce it since. However there are several other users who have experienced this so I would like to try and get to the bottom of it.

Does it happen for you on a new document?
Does it happen straight away or if you've been working on a document for a while (2-3 hours)?
What specs are your system including what graphics card you are using?

Thanks

Share this post


Link to post
Share on other sites

It always happens to me as soon as the file becomes more complex, it is still a matter of just moving objects, not to mention when I need to edit the texts. Instead I had no problems with corel draw even with very large files. My PC is an Aspire Timeline X notebook with Intel Core i3 8GB of RAM and HD SSD 250GB, dual video card an Intel and the other Nvidia Geoforce GT540M 1GB of RAM. Windows 10 64bit.

Share this post


Link to post
Share on other sites

I am also facing such an issue frequently.  For example, when I open the assets from Studio, it will freeze for some time. I have to wait for some time.  Then it will resume.

Share this post


Link to post
Share on other sites

Me too

 

Same Problem. CPU 16gb ram and Core i7

When the file become comples every 3-5 minute affinity designer freeze

Share this post


Link to post
Share on other sites

Going to bump this issue, as this is still happening on my machine with the most recent version of Designer (1.6.5.123) as soon as documents become a bit more complex these random freezes start to occur. Only for a few seconds but then the whole(!) system freezes, even music stops playing.

My suspicion is that this has something to do with the snapping tools as I have almost all snapping turned on, but I could be wrong obviously. Happy to send more info if required. Edit: nope, nothing to do with snapping

Share this post


Link to post
Share on other sites
3 hours ago, Andy81le said:

Going to bump this issue, as this is still happening on my machine with the most recent version of Designer (1.6.5.123) as soon as documents become a bit more complex these random freezes start to occur. Only for a few seconds but then the whole(!) system freezes, even music stops playing.

My suspicion is that this has something to do with the snapping tools as I have almost all snapping turned on, but I could be wrong obviously. Happy to send more info if required. Edit: nope, nothing to do with snapping

There is a known issue with having multiple files open, and snapping enabled (at the point the documents were opened). If you have multiple files open, chances are you're affected by this. Simply turning off snapping after the documents have loaded won't be enough to prevent it.

Share this post


Link to post
Share on other sites
7 hours ago, Mark Ingram said:

There is a known issue with having multiple files open, and snapping enabled (at the point the documents were opened). If you have multiple files open, chances are you're affected by this. Simply turning off snapping after the documents have loaded won't be enough to prevent it.

Thanks for the reply. I don't think that is the issue as I never had multiple files open. Another suspicion might be that it is somehow related to a bitmap file I have included in the file I work on. It sort of sits next to the graphics as a reference. Might that be the culprit?

Share this post


Link to post
Share on other sites

My project has a huge amount of objects which need to be aligned via snapping after inserting them. But everytime I try to move a group of objects, AD stutters and snapping doesn't work anymore.

  • Windows 10, 64-bit
  • Intel i5-6300U @ 2,40GHz
  • 16GB RAM
     

Share this post


Link to post
Share on other sites

I have the same problem with a specific image heavy PDF file which had been sliced up - Latest beta with snapping off seems to work as expected when I tested it. I enabled snapping to see if its causing slow down still and it had no effect so for my problem file the beta is a big improvement.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.