Jump to content
mjholtzem

[Fixed] Export Selection doesn't work properly for cropped objects

Recommended Posts

When using "Export Selection" on an object that has been cropped, the exported image includes the cropped out space as blank space.

 

Expected Result:

The exported image should match how the selection looks in Affinity Designer and properly exclude the cropped out space.

 

I have attached a .gif of reproduction steps and an image of the resulting export

 

post-61562-0-59534700-1498966639_thumb.gif

post-61562-0-56298600-1498966659_thumb.png

 

Edit:

After posting I realize it is a little hard to see what is going on in CropExportText.png so to clear it up, there is the word "This" with a large amount of white space to it's right.

Share this post


Link to post
Share on other sites

Hey mjholtzem,

I think you might be onto something but I'm not entirely sure if this is desired behaviour or not—I'll have to check with development. Thanks for raising this, I'll get back to you once I have feedback. 

Share this post


Link to post
Share on other sites

Not yet, sorry. I'll update the forum when development have looked into it. After looking into it some more, I would expect it to behave the same way as cropping an image so hopefully they will address this at some point. 

Share this post


Link to post
Share on other sites

Checking in once again. Kinda concerned about the apparent lack of attention Designer is getting from Affinity. No updates since like May even for pretty significant bugs like this

Share this post


Link to post
Share on other sites
On 23/09/2017 at 3:01 PM, mjholtzem said:

Checking in once again. Kinda concerned about the apparent lack of attention Designer is getting from Affinity. No updates since like May even for pretty significant bugs like this

 

There isn't a lack of attention, check out the beta forum where we regularly post beta versions that are available for testing, before we release the official 1.6 update:

https://forum.affinity.serif.com/index.php?/forum/33-designer-beta-on-windows/

 

Share this post


Link to post
Share on other sites
On 23/09/2017 at 3:01 PM, mjholtzem said:

Checking in once again. Kinda concerned about the apparent lack of attention Designer is getting from Affinity. No updates since like May even for pretty significant bugs like this

 

I've just checked this, and we fixed it a few weeks ago, so if you get the latest customer beta it will have this fix in it. Or you can wait for 1.6 to be official, but I don't know when that will be.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.