Jump to content
dysamoria

Filter and Layer behaviors (bugs)

Recommended Posts

While the twirl filter is active, (starting from the Interactive Introduction), tapping on the active layer will reset the position of the twirl, but not the amount or radius, so i assume this is a bug (due to inconsistency, it doesn't look like a "reset feature"). This also seems to happen inconsistently with live filters (after converting it to a live filter, i expanded the layer in the layer palette, tapped on the live filter layer, and the settings were reset, but i couldn't reproduce it a second time).

 

While the same filter is active, changing the opacity of the active layer with the opacity slider results in extreme flickering. Once the finger is removed from the slider, the opacity is shown seemingly correctly.

 

When it's a live filter there seems to be considerable problem with visibility. Parts of the layer are missing, or not updating, when toggling visibility, opacity, and changing filter settings (like the Twirl position), seemingly as a consequence of the live filter. Please see the screenshot attachment. EDIT: when i toggled away to another app and back to Affinity Photo, this corruption clears up, which validates that it's a bug, not some kind of hidden masking (sometimes zoom and pan will force a successful redraw, sometimes not).

 

Also, it would help a lot to have there be some kind of labeling on the filter controls panel to indicate to the user that they're working with a static filter or a live filter. There's really nothing on the screen that lets us know what we're doing if we've walked away and come back mid-action.

post-63804-0-18519800-1498804365_thumb.png

Share this post


Link to post
Share on other sites

Hi dysamoria

 

The controls when tapping or dragging on screen with a filter vary depending on each filter, however none of them are designed to reset anything. So in you twirl example it is only designed to change the position of the twirl and nothing else.

 

The flickering is a known issue and has already been reported. 

 

I've managed to get the rendering issue in both the interactive introduction and from a freshly created file so I shall pass this over to deveopment

 

there are some tell tale signs if a filter is live or not. In the controls you will get the lightening bolt, split view and accept/cancel  buttons if it is destructive. If it is live it will lack these options and have an opacity control on the toolbar along with the delete option, merge down, protect alpha and reset buttons, as well as being in the layers studio

 

cheers


Serif Europe Ltd - Check the latest news at www.affinity.serif.com

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.