Jump to content
cihelka

Photo: Batch Job - incomplete processing

Recommended Posts

Hello

Many thanks for developing so complex yet affordable editor.

I am facing strange behavior of batch processing.

I watned process 1300 timelapse shots (JPEGs) for preliminary video check. No big science, just small contrast adjustment and saving as resized JPEG.
I recorded a macro (curves + merging layers).
I set a batch job - macro, saving as JPEG resized to width 640. I selected all 1300 files and ran the job.
Everything went fine.

But I forgot to uncheck saving as Affinity format. So I deleted all files and set a job again with the same setting except saving in Affinity format - just JPEG. I was loking forward much faster processing.
But it surprisingly took more time. In addition I found that only roughly a half of shots were processed.
I ran series of tests but result was always the same - smooth and complete processing if Affinity format was also selected, slow and incomplete processing if only JPEG was selected (except when I selected only 500 shots - then all shots were processed but processing was also slow).

I found following:

Batch job with Affinity format
- processor load 100% continously
- disk load 100% continously
- memory load - nothing noticeable
- files list displays processing progress (green circle arrows)

Batch job only JPEG
- processor load 100% but there is dropdown to 0 every aprox. 15 seconds
- disk load 0%, rises to aprox. 15% when processor is down. Files are written, probably 8 x 2 files at the beginning, 8 x 1 file later, individual files at the end.
- memory load rises to full memory size, then drops a little bit and rases again. At that moment processor goes down except 1 thread, memory is very slowly released but no file is saved.
- Affinity looks like frozen, files list is displayed but no progress.

I made also test withour resizing, I decreased reserved memory, of course I switched Affinity off and on and I also restarted a computer but behavior was always the same.

Finaly I tried job which only saved JPEGs to other folder without mocro or resizing. Result was the same just memory was not used to full size. The same test with afphoto format was successful.

I have version 1.5.2.69

 

Regards, Tomas

Share this post


Link to post
Share on other sites

Hi Tomas,

Sorry for the delay in responding, thanks for your very detailed post. I've reproduced this and found that doing 1333 images saving with afphoto and jpeg took 26minutes using 100% CPU and about 70% RAM with 20% disk usage or so. After that completed (without shutting Affinity down) I added them again and did just JPEG and that then took 49minutes and 26 seconds using various amounds of CPU anything from 30-100%, however both disk and RAM usage were pretty stable at 100%!

When you did your tests did you close Affinity down before doing another batch process or did you leave it open and proceed to do another run? Also did you always do the AFPhoto and JPEG tests before doing the JPEG ones?

Going to run a couple more tests before I get it passed onto development!

Thanks again for your information.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×