Jump to content

Recommended Posts



I just installed Affinity Photo (trail), after installation the program and some others didn't work. Had something to do with an dotNET update to 4.7. After deinstaling all dotNET and a re installation of dotNET 4.6.2 all was fine again.


Then I just opend a photo (jpg) in Affinity Photo (trail) and start playing around using my Wacom tablet. Almost imidiatly the program had to think befor it did something, all movements I made started to lack behind. Then I looked at my CPU usage.


It was at 100% and stayed there even when I didn't do anything. After closing the program the CPU calmeddown. 


This is the same as in Lightroom 6, and Adobe isn't paying much attention to it. The main reason I'm looking for non adobe alternetives for Lightroom and Photoshop.


For me Affinety is new, saw some youtube videos and was sold. .....but now. I don't know yet?


Is it me, is it my computer or is it Affinity?


My PC is a:


Dell Xeon X5650 2,66Ghz

24Gb memory

NVIDIA Geforce GT 610

windows 7 64 bit


Let me please know what I can do.






Share this post

Link to post
Share on other sites

Hey Rob,


We seem to be noticing a lot of users report similar issues like this. Especially users who have lots of RAM. I'm not sure if that's coincidence or not. You should be more than capable of handling the app. We're currently trying to collect info from everyone reporting this but you've provided me with what I need to know so I'll add it to the notes. 

Have you tried using the app without the Wacom tablet connected? 

Share this post

Link to post
Share on other sites

Hi Chris,


No never tried used it without my tabled. But the following happened;


Didn't use it much during the trail period because it wasn't working well.

Then when I wanted to use it again the trail period was over. So I bought it anyway hooping it worked out fine.

And that seems to be the case at the moment. The program runs fine and I'm happy with it.


But I there is already a threat on this problem I'd like to know where it is. Could not find it. Maybe its better when I put my problems there when I have them in the future.




Share this post

Link to post
Share on other sites

Hey Rob,

Since you first posted, the app has had a ton of updates so this is probably why it is performing much better and I hope it continues to do so for you.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now