Jump to content
John Donovan

Windows Aero is not enabled

Recommended Posts

When I try to launch Affinity Photo, I get the following message. "Windows Aero is not enabled. This will cause rendering problems and slow performance. Please select an Aero desktop theme for best results". The programme then closes.

Share this post


Link to post
Share on other sites

Hi John Donovan,

Welcome to Affinity Forums :)

I assume you are using Windows 7. Select the Windows default Aero theme (to enable Desktop Windows Management Composition which is required for Affinity) and it should work without issues.

To do it, right-click on the desktop, select Personalize then click on Themes and select one of the default Windows themes.

Share this post


Link to post
Share on other sites
On 6/22/2017 at 11:59 AM, MEB said:

Hi John Donovan,

Welcome to Affinity Forums :)

I assume you are using Windows 7. Select the Windows default Aero theme (to enable Desktop Windows Management Composition which is required for Affinity) and it should work without issues.

To do it, right-click on the desktop, select Personalize then click on Themes and select one of the default Windows themes.

I did exactly this and I'm still having issues where I can no longer launch Affinity Photo after updating to the latest. This is a huge issue for my studio today.....

Share this post


Link to post
Share on other sites

I've just had this problem too.  There's another reason: you will get this message if you use Affinity via Remote Desktop.  It appears to be a bug: I can start Affinity from a local display, then move to remote desktop without stopping Affinity, and then continue on the remote desktop.

Share this post


Link to post
Share on other sites
6 hours ago, Groogle said:

I've just had this problem too.  There's another reason: you will get this message if you use Affinity via Remote Desktop.  It appears to be a bug: I can start Affinity from a local display, then move to remote desktop without stopping Affinity, and then continue on the remote desktop.

 

By doing it that way round, you start the application normally, which passes the checks, and then start remote desktop which disables DWM whilst the application is running. It's not a bug.

Share this post


Link to post
Share on other sites
On 29/08/2017 at 6:41 PM, Mark Ingram said:

 

By doing it that way round, you start the application normally, which passes the checks, and then start remote desktop which disables DWM whilst the application is running. It's not a bug.

If it can disable DWM started like that, why can't it disable it when I start it from remote desktop?  That can only mean that it's not absolutely necessary, so there's no reason for the start from remote desktop to fail.  In my book, as a former software support manager for a large computer company, that's a bug.

Share this post


Link to post
Share on other sites
8 hours ago, Groogle said:

If it can disable DWM started like that, why can't it disable it when I start it from remote desktop?  That can only mean that it's not absolutely necessary, so there's no reason for the start from remote desktop to fail.  In my book, as a former software support manager for a large computer company, that's a bug.

 

It's Windows that disables DWM, and we check on startup whether DWM is enabled. By starting the application first, you pass the check for DWM, then Windows disables DWM when you initiate a remote desktop session.

 

The checks are necessary, because Windows will use a legacy GPU driver when DWM is disabled (on Windows 8 and above DWM can never be disabled), so performance is affected, as well as visual bugs that wouldn't otherwise appear.

 

Finally, running the software via Remote Desktop (or inside a VM) isn't supported by us (if it works, that's great, but we don't test for those configurations, or provide support when it goes wrong).

Share this post


Link to post
Share on other sites

I get the same message even though I have an Aero theme as my desktop.  I have also checked and DWM is running as a service so, your answer does not solve this issue.

I also run Windows 7 x64 and have only just started getting this error.  I didn't even have an Aero theme as my desktop prior to this error occurring today, and Photo ran perfectly well.

Share this post


Link to post
Share on other sites

Guys,

 

I have just found the reason this is happening. Even though I had an Aero theme, I also had a mirror driver loaded and once disabled, Photo launched successfully.

In my case, it was LogMeIn Mirror Driver.  I went into Device manager and under Display adapters, found the mirror driver.  Aero themes do not function properly if you have a mirror driver installed.  Just disable any you find, reboot and you should be able to launch Affinity Photo normally after that.

image.png.97e3ab3c5aa05d9256914c0fc78324c8.png

Share this post


Link to post
Share on other sites
On 8/31/2017 at 6:35 AM, Mark Ingram said:

The checks are necessary, because Windows will use a legacy GPU driver when DWM is disabled (on Windows 8 and above DWM can never be disabled), so performance is affected, as well as visual bugs that wouldn't otherwise appear.

I'm having the same issue in AD. I think the warning is useful, but the application shouldn't close no matter what, because the bypass works. (In my case I had to ask a colleague to launch the app before connecting to the remote desktop.) Affinity should just ask something like, "This may cause rendering problemas ans slow performance. Do you want to continue anyway?"

Share this post


Link to post
Share on other sites

I too have had this problem. The work around I use is to stop DWM and the restart it.

admin command prompt. For the command prompt use net stop uxsms to disable and, then to restart use net start uxsms .

My problem originates in NVIDIA settings apparently.

regards, Mike

Share this post


Link to post
Share on other sites
9 hours ago, Mike from South Oz said:

I too have had this problem. The work around I use is to stop DWM and the restart it.

admin command prompt. For the command prompt use net stop uxsms to disable and, then to restart use net start uxsms .

Thanks, but doing it didn't make any difference for me. I still think the obvious solution would be for Serif to allow running their software regardless.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×