Jump to content

Recommended Posts

If you import photos from your iCloud Drive, it will work. Press the Stitch button before OK.

 

If you import photos from your iPad Photo Library, it won't work. The stitch button does not become active, so you can't stitch the photos together in a panorama preview. When you press OK at the bottom of the screen, the program will try to render the stitched panorama. But since there is none, it crashes. See attachment.

 

I have stitched and rendered panormas succesfully with JPEGs and very large 150MB 6000x4000 resolution 16 bit TIFFs from the iCloud Drive on my iPad Pro 12.9".

post-61432-0-61460300-1498126120_thumb.png

Share this post


Link to post
Share on other sites

If you import photos from your iCloud Drive, it will work. Press the Stitch button before OK.

If you import photos from your iPad Photo Library, it won't work. The stitch button does not become active, so you can't stitch the photos together in a panorama preview. When you press OK at the bottom of the screen, the program will try to render the stitched panorama. But since there is none, it crashes. See attachment.

I have stitched and rendered panormas succesfully with JPEGs and very large 150MB 6000x4000 resolution 16 bit TIFFs from the iCloud Drive on my iPad Pro 12.9".

What’s the problem with using local images?

Share this post


Link to post
Share on other sites

What’s the problem with using local images?

I don't know.

 

Way to work in short:

1. Select photos for panorama;

2. Press stitch button; photos stitched;

3. Press OK button; panorama rendered.

 

Panorama does not work when you select photos from your photo library to be stitched together as a panorama photo, because the stitch button (step 2) does NOT BECOME ACTIVE. It should, but it doesn't. It stays greyed out. So you can't press it and so your photos are not stiched into a panorama. And if you then press on the OK button (step 3), Affinity quits and you are back at your iPad home screen. Affinity can NOT render the panorama, because there is none stitched. The screenshot in my earlier post shows the Stitch button greyed out, after selecting photos from the Photo Library.

 

But when you select photos from your iCloud Drive to be stitched together as a panorama photo (step 1), the stitch button DOES BECOME ACTIVE. It is not greyed out and when you press the stitch button, the photos are stitched into a panorama (step 2). If you then click on OK (step 3), the panorama photo is rendered and it works as it should.

Share this post


Link to post
Share on other sites

I don't know.

 

Way to work in short:

1. Select photos for panorama;

2. Press stitch button; photos stitched;

3. Press OK button; panorama rendered.

 

Panorama does not work when you select photos from your photo library to be stitched together as a panorama photo, because the stitch button (step 2) does NOT BECOME ACTIVE. It should, but it doesn't. It stays greyed out. So you can't press it and so your photos are not stiched into a panorama. And if you then press on the OK button (step 3), Affinity quits and you are back at your iPad home screen. Affinity can NOT render the panorama, because there is none stitched. The screenshot in my earlier post shows the Stitch button greyed out, after selecting photos from the Photo Library.

 

But when you select photos from your iCloud Drive to be stitched together as a panorama photo (step 1), the stitch button DOES BECOME ACTIVE. It is not greyed out and when you press the stitch button, the photos are stitched into a panorama (step 2). If you then click on OK (step 3), the panorama photo is rendered and it works as it should.

This is a known issue and with development to be fixed.

Share this post


Link to post
Share on other sites

Recently started using Affinity Photo on my iPad Pro 12.9.

i can import RAW no problem (Canon 5D ) from either Cloud or Photo app.  When selecting for Pano, I can also select and import RAW files from Photo app. So far I have completed about 3 panos with 3 files each. However, if I go any larger...eg 4 or 5 files, the process will continue ok until pano rendering...then Affinity crashes with no warning and importantly no save...back to square one. There was also one crash in Photo persona.

No other apps running after a clean boot. This became very unpredictable and frustrating. I finally managed to do a 5 file pano by linking the first two, completeing the process, then adding another file, completeing the process....etc until all 5 files included.

i have the latest iPad Pro 16Gb with 256Gb.

i have read and noted the comments above, and am wondering if this is still a known issue to be addressed, or will I have to take my MacBook with me in future instead of the preferred iPad Pro.

Share this post


Link to post
Share on other sites

Thanks for the reply Sean....I'll attach the files below. I updated Affinity Photo the other night after the pano crashes....might have been fixed but haven't checked it yet.

Just waiting for these files to upload...i might mention another little bug...after watching one of the tutorial videos from within the program, if I select another one Affinity crashes. If I restart...i can then watch another....weird.

Had to reload a couple of files...but they're all there now

375C3027.CR2

375C3028.CR2

375C3030.CR2

375C3031.CR2

375C3029.CR2

375C3030.CR2

Share this post


Link to post
Share on other sites
10 hours ago, DGL said:

Thanks for the reply Sean....I'll attach the files below. I updated Affinity Photo the other night after the pano crashes....might have been fixed but haven't checked it yet.

Just waiting for these files to upload...i might mention another little bug...after watching one of the tutorial videos from within the program, if I select another one Affinity crashes. If I restart...i can then watch another....weird.

Had to reload a couple of files...but they're all there now

 

Thanks for the files. I've just tried it myself on a 2015 iPad Pro 12.9" and was unable to reproduce it using the latest App Store version of Photo. Did yours improve after updating?

Share this post


Link to post
Share on other sites

Sean...I reworked the pano with the 5 big raw files this afternoon and NO CRASH...well done to Serif for the update..seems to have fixed this problem...many thanks

Share this post


Link to post
Share on other sites
15 hours ago, DGL said:

Sean...I reworked the pano with the 5 big raw files this afternoon and NO CRASH...well done to Serif for the update..seems to have fixed this problem...many thanks

Wonderful! Thanks for getting back to me :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×