Jump to content
AllenArt

App crash using selection persona

Recommended Posts

I have been using the app for a week and am really interested in its RAW processing capabilities. I have been experimenting using the selection persona to extract a dandelion flower from its background. A relatively simple task to my mind. Whilst the selection tools are some of the easiest I have come across on iPad or PC I find that if I make too many refinements to the mask the app crashes and I loose the work I have done in the selection persona.

 

I have achieved a successful selection and export eventually by not zooming in on the image but this negates the ability to make really fine selections. I am running an original iPad Pro 12.9 using an Apple Pencil and am up to date both with iOS and the latest version of the app (updated this evening).


www.allenart.co.uk

www.sozobsh.co.uk

Share this post


Link to post
Share on other sites

Same here. I also had a crash after the selection was converted to a mask and I'd started working on another layer. After reopening the app, I was back to a very early stage in my selection, and the app crashed again almost immediately once I got into the refine selection tool. 

Share this post


Link to post
Share on other sites

Same here. I also had a crash after the selection was converted to a mask and I'd started working on another layer. After reopening the app, I was back to a very early stage in my selection, and the app crashed again almost immediately once I got into the refine selection tool.

 

What iPad are you working on I am wondering if it is a memory issue what with the new Pro's having higher spec ram.


www.allenart.co.uk

www.sozobsh.co.uk

Share this post


Link to post
Share on other sites

Hey AllenArt,

 

Were you using the Magnetic selection tool? We logged this internally last Friday. It looks like it may have a fix but I'm not sure when that will be pushed to release. Hopefully it won't be long. Once you've updated the app please try again and let me know how you get on as we will be checking it too. 

It might not be restricted to the Magnetic tool however we found the crash was easier to reproduce with it.

Share this post


Link to post
Share on other sites

Hey AllenArt,

 

Were you using the Magnetic selection tool? We logged this internally last Friday. It looks like it may have a fix but I'm not sure when that will be pushed to release. Hopefully it won't be long. Once you've updated the app please try again and let me know how you get on as we will be checking it too. 

It might not be restricted to the Magnetic tool however we found the crash was easier to reproduce with it.

Yes I was, if that's the one that automatically selects tones of the same colour and snaps to the edges that it detects?


www.allenart.co.uk

www.sozobsh.co.uk

Share this post


Link to post
Share on other sites

Yep! It should be fixed in the next retail update :)

 

Great! This has been a pain...

 

Probably linked, interesting though as it has only recently happened, when using the Smart Selection Brush Tool and 'add' is the mode in the context tool bar, there is a long delay in the selection process. 

 

I also get this same delay after a selection and refine has been made and then moving the object around on screen...

 

 

 


About me: Trainer at Apple, Freelance Video Editor, Motion Graphics Artist, Website Designer, Photographer. Yes I like creating things!!!

Instagram:https://www.instagram.com/mystrawberrymonkey/

Twitter:@mystrawmonkey  @imAllanThompson

Web: mystrawberrymonkey.com  Portfolio: behance.net/allanthompson

YouTube: Affinity Designer & Photo Tutorials

Share this post


Link to post
Share on other sites

I've noticed this too. I'm confident we'll improve these things over time though. The difference from the first build we ever saw to what we have now is amazing.

Share this post


Link to post
Share on other sites

My problem is after i make a selection and go into refine, the app crashes and I lose everything, happened 3 times now, very frustrating. I'm using a new iPad pro 10.5 so more than a little disappointed..

Share this post


Link to post
Share on other sites

I'm quite a few builds ahead of public release and the refine section seems to be a lot more stable. When it gets pushed to release can you give it a go and give me some feedback. I don't have an ETA yet but it won't be long. 

Share this post


Link to post
Share on other sites

Same issue here. Brand new user and I can't get through my first test of the app without crashing on selection refinement.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.