Jump to content
Kal

Frozen during save

Recommended Posts

Illustrator user of 20+ years here, and new to Designer. So far I'm liking what I see! But I have come up against my first major bug, and it's a good one…

 

Upon hitting enter in the save window, the app appears to have frozen. The Save window is still open, but looks somewhat greyed out. The maximise button on the window works, but everything else is unresponsive—the window can't even be moved.

 

If I right click on the app's icon in the Dock, I can see what appears to be a recent history of open files, and surprisingly, I can click on each one to open it, whereby it becomes visible behind the frozen save window, but in all other respects the program appears to be unresponsive. I can't bring the main window in front by clicking it, and all the menu items are greyed out.

 

So I did a force-quit, and lost the file I was trying to save. Upon relaunching Designer I said yes to recovering the unsaved file, and it restored it partially (not as it was when I tried to save unfortunately).

Share this post


Link to post
Share on other sites

Hey Kal, welcome to the Affinity Forums.

I'm sorry to hear you lost some of your work. Do you think you could reproduce this again or would you say it was a one-off? It almost sounds like another dialog window appeared somewhere preventing you from interacting with the Save dialog.

 

Share this post


Link to post
Share on other sites

Thanks Chris. (Pardon my delayed response—just got back from a long weekend away.) I'm guessing (and hoping!) that it was a one-off, but I'll be sure to let you know if it happens again.

 

Yes, I have had that kind of thing happen with Adobe products, typically when I switch from my big external monitor to the laptop display, and some dialog pops up almost entirely off the screen. I didn't get the sense that was happening here, but maybe. When I say 'somewhat greyed out' it didn't quite look the same as a typical background window, but the file-viewing part of the window was empty (solid grey) if I recall correctly. Not sure now why I didn't think to just take a screenshot of the window!

Share this post


Link to post
Share on other sites

 Not sure now why I didn't think to just take a screenshot of the window!

Well if it happens again, I'm sure you'll remember  :P but hopefully it won't. I'll see if I can reproduce it with as you've mentioned you are using an external monitor. We have to take any work loss quite seriously. Thanks for getting back! 

Share this post


Link to post
Share on other sites

Great, thanks. In case it's helpful, a bit more about my setup and how I was using the software when it froze…

 

MacBook Pro (15-inch, Early 2011), with one of those old 30 inch Apple Cinema Displays. After using the Save shortcut, I navigate to the correct folder by dragging the folder icon (or a file from within the folder) from the Finder into the Save window. I then edit the file name and hit Enter.

Share this post


Link to post
Share on other sites

Sorry to jump in on this, but I've just had the exact same thing happen to me!  I googled it and found my way here.  I haven't force quit yet as I didn't want to lose what I was working on.  The cursor is flashing in the file name entry field, the save button is greyed out now and is unresponsive.  I too can toggle in and out of full screen, I can access the top bar menus for Affinity Designer, but most options are greyed out.  I'm on both the latest OS and latest Affinity software as of right now and I'm running on a 2017 MBP 15" so it shouldn't be that....

 

Any ideas for a way I might be able to rectify this without losing the work?

Share this post


Link to post
Share on other sites

I am having the same issue and I have experienced it more than once. The system freezes and I am able to view my work but unable to use any of the functions on the program i.e save. I am forced to quit and restart the application. Some projects I have been able to partially recover whereas others I've lost the entire piece. How can I resolve this issue? In addition, is there an option for the app to autosave after a certain period of time? 

Share this post


Link to post
Share on other sites

I'm continuing to have the same issue with 1.8 on my iMac using a Cintiq 24 display.  It's like playing Russian roulette whenever I save.  I never know when it will happen, but I'm always anticipating it.

Share this post


Link to post
Share on other sites
17 hours ago, pauldraws said:

I'm continuing to have the same issue with 1.8 on my iMac using a Cintiq 24 display.  It's like playing Russian roulette whenever I save.  I never know when it will happen, but I'm always anticipating it.

You should not have to work like that. Where do you normally attempt to save? Locally, cloud, usb? You may have seen but we always recommend saving locally and using a cloud or usb to backup the already saved file.

Does the app just freeze/lock up as opposed to crash?

Share this post


Link to post
Share on other sites

I keep having this issue and having to force quit, and loosing work. I save all the time as I keep having this issue but then one save just won't work -  Its making me want to stop using the software ! 

Share this post


Link to post
Share on other sites

Hi Dionne,

Can you answer the above. We need to know where you save files to etc. Do you get crash reports or does it just freeze?

Please confirm your OS version too.

Share this post


Link to post
Share on other sites

I have this issue chronically with both Photo and Designer and I have updated to Mac OS 10.15.4. Usually there is a recovery file, but I have to force quit after trying to save (and even occasionally opening).

As far as I can tell, Affinity products have always had issues with the file system. I do love the tools and would love to be free of Adobe, but this instability is a pretty huge issue.

Share this post


Link to post
Share on other sites

Having the same issue here. OSX 10.15.3
This s baaaaad. I lost a lot of work already!

Wassup guru, any milk and cookies on the horizon?

Share this post


Link to post
Share on other sites

Is this from File > Save, File > Save As? Do you select an existing file and replace it? Do you save locally or to cloud? If you save to cloud, which one? 

We need more info. We cannot possibly diagnose or fix something without being able to reproduce your environment/setup. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.