Jump to content

Recommended Posts

I'm trying to just get a basic brush but everything that says 'reset' doesn't rest them (under more button and also under preferences pane)...any other ideas or is this a bug?

Share this post


Link to post
Share on other sites

Hi sgseries,

Welcome to Affinity Forums :)

I'm not sure I understood you. Do you want to reset the application brushes to the default ones? If so the Reset Brushes button in the Preferences, Miscellaneous section should do it. If it doesn't work you can also try to press and hold ⌘ (cmd) while launching the application (from the Launchpad or the Applications folder) tick Reset Brushes from the dialog that will open and press the Clear button.

Share this post


Link to post
Share on other sites

That doesn't work - i'm still using this same stupid hair like brush for everything haha. I got about 1 more job in me before i switch out for another program..

Share this post


Link to post
Share on other sites

Hey MEB,

 

So yeah, still stuck on this brush, it's been about a year now so i can't remember to be honest however i feel like i ended up there making adjustments to cut around some hair, it never changed back since then.

Screen Shot 2017-12-16 at 5.49.51 pm.png

Share this post


Link to post
Share on other sites

Also experiencing this bug. Once the brush is changed it can NOT be reset. 

 

Using the Reset button in this Dialog doesn't do anything.

Using Preferences > Miscellaneous > Reset Brushes doesn't help

Restarting the application doesn't help.

 

 

 

Mac 10.13.3 Beta (17D29a)

Affinity Photo 1.6.6

 

Share this post


Link to post
Share on other sites

I ended up purchasing a 12 month Photoshop sub. Still using affinity designer but the other one is useless as long as this brush thing keeps happening without explanation.

Share this post


Link to post
Share on other sites

I have been doing a new Udemy course about Photo and as part of this, I was experimenting with tweaking the various brush settings as outlined in the videos about brushes. When I hit the reset button, the original, untweaked settings did not reappear. The only way to get them back was to write them all down ahead of time and manually reset them.

 

When I contacted the instructor about this, he suggested that it might be a bug in the program and suggested contacting Serif tech support. A search for this issue led me to this forum where the issue appears to be unresolved.

 

I understand that I can restore the factory settings through the Preferences menu, but I believe that will also undo any new or customized brushes that I created and want to save. 

 

Are my only options to export my own brushes prior to resetting the brushes through this menu? Or to duplicate each brush that I might want to tweak before playing with the settings? Both of these options seem clumsy. So I'm wondering if this is a bug that needs fixing.

 

Thanks for any thoughts about this.


Affinity Photo, V 1.7.1    Affinity Designer, V 1.7.1

Imac OS 10.13.6 ( High Sierra)

Share this post


Link to post
Share on other sites

Thanks for the quick reply, MEB, and also thanks for bring this to the devs attention. This would be a great bug to fix given the power of the brush tweaking ability.


Affinity Photo, V 1.7.1    Affinity Designer, V 1.7.1

Imac OS 10.13.6 ( High Sierra)

Share this post


Link to post
Share on other sites

Same issue for me, too. The feature works, until you close the dialogue box for the brush settings the first time. What I mean by that is, you could select a default brush, open the brush editing window, mess around with it as much as you like and the reset button will work as intended. However, if you close the brush editing window, it seems to lose all knowledge of the default settings. In essence, the reset button only remembers the settings from when you last tried to edit the brush, anything prior to that is lost. What it needs is the ability to reset to default settings, or reset to the settings the brush had when you tried to edit it last. That way, you can retain the settings you've applied to the default brush, or revert to the default settings if need be.

 

I had a host of custom brushes I'd downloaded, and using the 'reset brushes' function deletes everything you've ever installed, or created yourself, so avoid it like the plague (unless you have nothing to lose). One click of a button removed many, many hours of time and dedication, so be warned, use it as a last resort, becuase you will lose everything in relation to brushes.

Share this post


Link to post
Share on other sites

I've also run into this bug. Very frustrating - please fix. Is this bug fix scheduled for a future release yet?

Edited by Shmuel
get more clarity

Share this post


Link to post
Share on other sites

This is still an issue more than a year later!!! Affinity devs.... Mac users can't reset any of the brushes to default after adjusting them. The rest button for the individual brush AND the rest all brushes in preference does not work. This is really really frustrating. Experimenting with and changing brush settings is an important part of digital design work. But you have to be able to get back to baseline to judge what each setting does or even remember what the brush originally can do.

The last response from devs on this post is from MAY, it's January now, and this was brought to Affinity's attention in June 2017! Come on now... we need a functioning reset button, please.

Share this post


Link to post
Share on other sites
On 1/2/2019 at 7:12 AM, dropbars said:

This is still an issue more than a year later!!! Affinity devs.... Mac users can't reset any of the brushes to default after adjusting them. The rest button for the individual brush AND the rest all brushes in preference does not work. This is really really frustrating. Experimenting with and changing brush settings is an important part of digital design work. But you have to be able to get back to baseline to judge what each setting does or even remember what the brush originally can do.

The last response from devs on this post is from MAY, it's January now, and this was brought to Affinity's attention in June 2017! Come on now... we need a functioning reset button, please.

Hello!

I had this same issue and found a simple solution. When you got the paint brush tool selected, go to the panels on the right and select the brushes tab (next to colour, swatches, stroke, ...). If you select a default brush there, the custom changes you applied are no longer active. I guess they want you to make a custom brush and don't lose it if you accidentally reset the panel (dunno). But his is what fixed my issue! You can later use your custom brush as well!

Hope this helps someone stuck with the same issue!

Share this post


Link to post
Share on other sites

I have the same problem on AD under Windows, so this seems not to be restricted to Mac users. What Bob3s suggests does not help, that is how I select a brush all the time and once I changed one and used it, there is no way to reset the single brush. So it seems, knowing this, the only way is to never change a brush without duplicating it first... 

Share this post


Link to post
Share on other sites

I also have this bug on Windows. Actually, reset buttons across Affinity Photo don't do anything at all, not just in this brush area.

 

Pretty bad this has not been fixed since 2017.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×