Jump to content
Sign in to follow this  
Miroku

Raw Image Sharpening

Recommended Posts

Hi,

 

After using Affinity Photo for a few days (Bought from App Store) I have a small problem with developing Raw Files.

 

After importing I develop the file and everything looks fine.

 

Now I click the develop button and now the image suddenly gets a little darker and all sharpening I have done to the file returns to a very soft look.

I now have to add the sharpening again in Photo Persona.

 

The image in develop Persona is not the same as the image in Photo Persona. Something gets lost in between here.

 

 

Miroku

Share this post


Link to post
Share on other sites

Hi Miroku,

Welcome to Affinity Forums :)

Affinity Photo uses mipmaps - lower resolution versions of the image - to improve its performance when rendering images on screen at different zoom levels (below 100%). What you are seeing is the result of the Detail Refinement (sharpening/Clarity) being applied to one of these lower resolution versions. When you hit Develop the adjustments are backed to the full resolution image instead and then displayed on screen thus the differences you are seeing between the two. To prevent this and get an accurate "preview" of the adjustments make sure you are seeing/checking them in Develop Persona at 100% zoom or higher to ensure they are being applied/previewed using the full resolution version. 

 

Same happens when working with filters/adjustments in Photo Persona - in particular noise-based ones - it's recommendable setting the zoom level to 100% to ensure you get an accurate preview/rendering of the effect.

Regarding colours they should look identical on both Develop and Photo Personas - please make sure you are comparing them at 100% zoom. Let us know if this is not working correctly for you.

Share this post


Link to post
Share on other sites

Hi,

 

Ok I undestand.

 

Have another question. I have a Nikon D5300 and uses Raw files only. When I used the Beta version of Affinity Photo I could select and set the color profile to Prophoto RGB in the develop module.

Now this is gone, can't find or select it, only srgb among some others

 

My question.

My camera is set to shoot in srgb but I guess this only matters for jpeg files not raw files.

I know that Prophoto give you more colors to work with so I am not sure why its gone from the list. Adobe 98 and Adobe rgb among several others is there.

 

So what do I choose? and why is it suddenly gone?

I doubled checked the camera and the settings haven't changed.

 

Miroku

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.