Jump to content
Space Panda

Cursor changes when moving over to right-hand panels

Recommended Posts

When I move the cursor rightwards into one of the panels on the right hand side (like the layers panel), it changes shape as it crosses the left edge of those panels. It changes into the 'resize' cursor that is used for resizing the width of the panels on the right hand side. Normally the cursor changes back into the 'pointer' cursor after the cursor has fully crossed past the left edge of the panels. But sometimes the cursor stays as the 'resize' cursor, normally if the cursor crosses the edge at a specific speed. This is kind of annoying as I want to use the pointer cursor, not the resize cursor, when clicking on things in the panels on the right hand side. The only way to get the pointer cursor back is to click on something in one of those panels or move the cursor back into the area in the middle of the window (I'm not sure what that is called). Does anyone else have this problem?

Share this post


Link to post
Share on other sites

I have recorded and attached a 37 second video file. It shows me moving the cursor back and forth across the left edge of the right hand panels to try and demonstrate the cursor changing shape permanently to a resize cursor. After the first time it changes to a resize cursor permanently, I then click on the object layer to bring back the pointer cursor. I then try and demonstrate the problem again to show that moving the cursor leftwards into the centre of the window also brings back the pointer cursor.

screen recording of Affinity Designer cursor changing problem.mov

Share this post


Link to post
Share on other sites

Hi Space Panda, cabyambo,

Welcome to Affinity Forums :)

Do you have any window manager utilities running on your Mac? If so disable them and check if the problem still persist.

You can also try to create a new user account and check if it also happens there. If not there's something interfering with the app in your regular account.

Share this post


Link to post
Share on other sites

Hi MEB,

 

Thanks for your reply. I don't have any window manager utilities running. I actually have a similar problem in Logic Pro and in the Launchpad. So, as you suggest, it may be that something is wrong with my user account. I was also thinking that maybe I could try reinstalling the operating system.

Share this post


Link to post
Share on other sites

I just checked whether or not the problem is something to do with my user account. I already had a separate admin account to my regular standard account, so i just logged in to that admin account and the problem still occurs there.

Share this post


Link to post
Share on other sites

Hi MEB,

 

I just did a clean install of Mac OS prior to buying the program, so there's only three applications on my laptop in total, and none of them are window managing utilities. Is there a solution to this bug?

 

And this only happens in Affinity designer for me, so I don't think its a problem with my operating system.

Share this post


Link to post
Share on other sites

Hi Space Panda, cabyambo,

I'm able to reproduce this here too. It's not something related with the OS but with the program itself. Seems it fails to detect the "end of the edge" (when crossing the left edge of the panel) in certain circumstances. I'm logging this but i believe it will be considered a lower priority issue since it's relatively difficult to reproduce on regular use and clicking inside the panel updates the cursor immediately. In any case it's up to the dev team to decide.

Share this post


Link to post
Share on other sites

Same problem here, Imac 27" retina desktop, the problem arises when you move the cursor from the canvas to the left or right tool panel, but only happens if you move the cursor at certain speed.

Workaround: Move the cursor faster (or some times slower) into the panel.

Share this post


Link to post
Share on other sites

Having this issue as well.  It's incredibly disruptive causing a mental context reset every time this occurs... which is quite often.

13" MBP - Early 2011  |  High Sierra 10.3.6  |  Intel HD Graphics 3000 512 MB

Share this post


Link to post
Share on other sites
On 5/1/2018 at 3:19 AM, MEB said:

 I'm logging this but i believe it will be considered a lower priority issue since it's relatively difficult to reproduce on regular use

It's literally not difficult to reproduce with 'regular use' as it happens constantly.    Also,  difficulty in reproducing the bug is not the determining factor in the priority level.  It's the *impact* of the bug that should determine the priority.   And in this case, even though it seems like a silly bug with a work around, it is a *very* disruptive bug that interrupts mental concentration and focus to deal with.  And with the frequency that it occurs, it is a constant, nagging and frustrating issue to deal with.   The fact that it has been reported so many times should indicate this.

Please re-evaluate with the dev team to increase the priority on this.

Share this post


Link to post
Share on other sites

Hola, a mi me pasa algo similar, pero con el cursor tipo "Mano" cuando aprieto el atajo de la tecla espaciadora, y empiezo a moverme por la aplicación, ya no regresa al Cursor normal "puntero". Esto pasa aleatoriamente, en los 3 programas de affinity (publisher, designer y photo) ¿alguna solución?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.