Jump to content
shushustorm

Values used by macros not stored reliably

Recommended Posts

Hello everyone!

 

I have been running into this many times.

When trying to create macros, the values saved sometimes change when trying to access the macro later.

This is very bad.

 

Especially since it completely destroys the purpose of using macros, which is saving time.

So basically, I have to create some of the macros from scratch all the time.

This happens especially after closing and opening documents or Photo itself.

Also, especially transform and crop values seem to be very fragile.

 

For example, scaling on X by 50% and on Y by 50% results in scaling by 200% on X and 200% on Y.

If I remember correctly, values sometimes even store asymmetrically (for example, 50%, 50% resulting in 200%, 100%).

 

To reproduce, please try to create a macro for scaling a layer by 50% and one for scaling it by 25%.

Then, create a macro for cropping the document by 50% and one for cropping it by 25%.

Those are 4 macros that I frequently use and which very frequently break.

 

Can somebody look into this and confirm this as a bug? And maybe somebody can fix this?

Or could I be doing something wrong? I do save the macros to the Library.

 

Best wishes,

Shu

 

EDIT:

Software used:

Affinity Photo 1.5.1, Affinity Designer 1.5.1, OSX 11.6

 

EDIT 2:

Alright, after posting this, I created a new macro. But it didn't take a long time for it to break.

When creating it, the values were set to 50% and 50% for both X and Y, but now, after clicking on the macro without anything happening, I tried to edit the macro, which showed me the 50% values have been set to 100% by itself resulting in no scaling at all:

 

MacroBug.thumb.PNG.9b92c4903d745eeb3e007e7a09803eb4.PNG

Share this post


Link to post
Share on other sites

Hey shushustorm,

I'll be honest, I'm struggling to reproduce this. I did however find a crash so I have to thank you for that.

 

I've created 4 macro's like you said; 1 for 50% and 1 for 25% scaling and finally 1 for a 50% crop and another for a 25% crop and testing this on Shapes it seems to be working fine.

 

Can you export your Macro's so I can try them my end? Perhaps even record a short clip of this happening? 

Share this post


Link to post
Share on other sites

Hey Chris B!

Thanks for trying to reproduce this! I just wanted to create a screen recording from this happening in a very basic test file, but I was unable to reproduce this twice.

Maybe this only happens when working with a lot of files and layers or I have just been "unlucky" when trying to reproduce.

Unfortunately, I cannot record the screen all the time when I am working. However, if I find out about more specific conditions that this issue needs to show up, I will let you know.

Also, I can export the Macro when I run into this again. Right now, I don't have much work to do with Photo, though, so this may take a while.

Share this post


Link to post
Share on other sites

Alright, it just happened again.

I was able to reproduce it after starting Photo again and trying to scale a layer using the macros I created a few hours ago.

 

When I try to edit the Makros, I see the functions that are being performed:

 

Makro "scale05" (supposed to scale X by 50% and Y by 50%):

Transform:

-> Scale X: 159

-> Scale Y: 239

Transform:

-> Scale X: 319

-> Scale Y: 120

 

Makro "scale025" (supposed to scale X by 25% and Y by 25%)

Transform

-> Scale X: 80%

-> Scale Y: 60%

 

The Makros I made for cropping earlier today also crop like crazy.

"crop05" (supposed to crop by 50% of X and Y)

"crop025" (supposed to crop by 25% of X and Y)

 

Unfortunately, I cannot inspect the crop Makros any further.

When I try to edit them, it just says "Raster crop" with no option to take a look at the values by which the image gets cropped.

Both crop Makros crop the image to a square, not considering the original aspect ratio.

Also, the cropped area results in a much lower resolution than 50% for "crop05" and 25% for "crop025".

 

I don't know if this had an effect on the Makros, but I did reboot at some point (including closing all the documents and quitting Photo).

 

Finally, I exported the Makros (Category "TEST") and uploaded them:

TEST.afmacros

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.