Jump to content
ronnyb

Color Swatch issues

Recommended Posts

Some issues I've noticed with Color Swatches:

 

1. If I create a color swatch using the Gray Slider color palette (and even using thethe built-in color Grays color palettes in AD) and then proceed to inspect the values AD uses by switching to the CMYK sliders color palette, AD converts the 1 channel (grayscale) swatch into a 4 color blended CMYK "gray", not a true C: 0%, M: 0%, Y: 0% and the K% (black) channel corresponding to the original value in the Gray slider-defined swatch. See attached images for reference.

 

2. Furthermore, if I double click on the color and open up the expanded color palette with all the HSL, Hex, RGB, RGB# and CMYK fields, my supposedly neutral gray has a certain amount of saturation in the HSL readout, and the RGB values are not equivalent, meaning the Gray  I defined is not neutral anymore and has a color cast. 

 

3. The grayscale palette should simply be a horizontal gradient from black to white, not a full color palette converted to grayscale, as is currently the case. (See attached screenshot)

 

4. Is the Grayscale sliders color palette backwards? Meaning when I type in a gray of 17% it's actually showing a Gray of 83%. If you go into photoshop and adjust type in 17 into the Gray slider input field, you will see what I mean. (image attached for your reference.)

 

5. I went to rename a color palette. I used the standard keyboard short-cut for navigating and selecting text in the rename field, but AD's text tool interpreted the command and didn't let me jump backward or forwards between words inside the rename field. See attached image for reference.

post-1105-0-51330200-1420620769_thumb.png

post-1105-0-72929100-1420620792_thumb.png

post-1105-0-77470300-1420623120_thumb.png

post-1105-0-93434100-1420623296_thumb.png


2017 15" MacBook Pro 14,3 w/ Intel 4 Core i7 @ 2.8 GHz, 16 GB RAM, AMD 455 @ 2 GB, 512 GB SSD, macOS High Sierra

Share this post


Link to post
Share on other sites

I see this also. I am working in CMYK but my PDF and EPS files are exporting as RGB. When I go to seperate for press, the files are wrong and I have to change it in acrobat. Is there something I need to do too?

Share this post


Link to post
Share on other sites

Bryce, PDF and EPS should export in the document's colour model. Are you using CMYK colours in an RGB document? You can find out the colour model from the Document Setup dialog.

Share this post


Link to post
Share on other sites

Hi Dave,

 

Sorry I didn't get back with you right away. Yes, I did make sure that the colors in the Document Setup was CMYK and also in the swatch. The file was originally CMYK PDF and then imported into Affinity. When exported it turned into RGB in seperations in Acrobat which is what we preflight everything through.

 

Can Affinity show seperations?

Share this post


Link to post
Share on other sites

I can't figure out how to attach the file. I did notice that if I edit the embedded content and then export it from there it is okay (CMYK/8 and vector). But when I close the embedded content and export the main file (terminology?) it comes out as RGB and it's rasterized instead of vector. Is there a reason the color and content is not transfering to the main file? I have set the main file to CMYK also.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×