Jump to content
anweid

Strange behaviour of the dialog 'Edit text style' (lots of bugs)

Recommended Posts

[in this post, I'm guessing the English on-screen text, because I'm using the German version of Affinity Designer 1.5.2.58 on a German 64-bit Windows 7]

 

Strange behaviour 1 (text baseline): The 'Edit text style' dialog doesn't immediately transfer its baseline settings to the selected text. Try the following:

  • Create a new document with a block text containing one paragraph spread over two lines, format this text with the paragraph style 'Heading 1', and keep the block text object selected.
  • In the text styles palette, right-click on 'Heading 1' and choose 'Edit Heading 1' to show the 'Edit text style' dialog.
  • In 'Position and transformation', change the kerning or character distance in permille. The selected text block immediately reacts and shows the desired changes. Wonderful - that's what should happen.
  • Now change the baseline. Nothing appears to happen. Only when additionally changing kerning or character distance (or anything else), the changed baseline settings become visible in the text object. Sometimes, even kerning or character distance changes in one direction (with the up/down arrows) don't do the trick, but one needs to change these in one and the other direction to make it work properly.
  • Set the baseline to a negative value for the time being (e.g., -24pt), ensure that the -24pt baseline is really working properly, and close the dialog with 'OK'.

Strange behaviour 2 (text baseline): The 'Edit text style' dialog transfers the current text's baseline into its edit fields with the wrong sign. Try the following:

  • Right-click on 'Heading 1' in the text styles palette, and choose 'Edit Heading 1' to show the 'Edit text style' dialog again.
  • Though the baseline was previously set the minus 24pt, the edit field now shows a positive 24pt.
  • Changing kerning now by some reason keeps the text's negative baseline intact, though a positive baseline is shown in the edit field.
  • When changing the positive '24pt' baseline to '23pt' with the up/down arrows, nothing seems to happen (see above). Changing kerning additionally now makes the baseline jump from the previous -24pt to a real +23pt.
  • Closing the dialog with 'OK' and opening it again now shows a negative 23pt baseline where a positive one should be shown.
  • Change the baseline to zero and make sure changes are accepted to avoid this confusion for now, and close the dialog with 'OK'.

Strange behaviour 3 (distance correction): Try the following:

  • Open the dialog again. Note that the baseline is now displayed as minus 0pt, but we will ignore that...
  • The 'distance correction' (or whatever it is called in English) below the baseline is now shown as '0pt', and the two-line text object looks 'normal'.
  • Changing the '0pt' to '1pt' and back again to '0pt' makes the two text lines completely overlap each other, so that the text is unreadable.
  • Changing the distance correction to 'auto' resolves that problem and makes the text appear 'normal' again.
  • It appears that the default setting for the distance correction is 'auto', but that is not what is displayed when opening the dialog. Instead, an apparently wrong '0pt' is displayed, which leads to confusion.
  • Sometimes, after changing the distance correction to some undesired point value, choosing 'auto' from the drop down combo does not transfer 'auto' into the edit field, but leaves the previously entered point value in it, creating additional confusion. Sometimes, even manually typing 'auto' into the edit field and pressing RETURN throws away the manually entered 'auto' text and replaces it by the previously entered point value, making it impossible to ever get the automatic spacing again...

Strange behaviour 4 (font attributes): Try the following:

  • Now show the dialog page where one can select the font family and choose a family that has several attributes available, e.g., regular, bold, italic and bold-italic. The font attributes are still set to 'No change'.
  • Now set the font attributes to 'Regular', switch to the dialog page 'position and transformation' (without changing anything there) and back to the page 'font'. Now, the attributes previously set to 'Regular' appear as 'No change' again.
  • For the second time, switch to the dialog page 'position and transformation' (without changing anything there) and back to the page 'font'. Now, the attributes display as 'Regular'. Very confusing...

Over the weeks of using that dialog, I found even more than the above confusing things with it, which I just didn't care to put into writing. Anyway, this dialog seems to be quite confusing and unreliable to me, with lots of strange side effects that make predicting its outcome rather difficult...

 

Andreas Weidner

 

Share this post


Link to post
Share on other sites

Still having lots of problems with text styles in AD - it's so frustrating. I create a style and when I want to use it it's not the same as the style I created.


iMac: iMac (Retina 4K, 21.5-inch, 2017)  -   3.4 GHz Intel Core i5   -   8 GB 2400 MHz DDR4  -  Radeon Pro 560 4096 MB 

Windows: Nvidia gtx 960m 4k uhd 2gb ram video (Windows 10 Pro) -  Laptop screen (resolution 3840x2160 magnified 300%)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.