Jump to content
Mariosaverino

Is Any One Having This Problem When Moving Objects?

Recommended Posts

Hi All -

Working in Affinity Designer and have been having many problems with moving objects around.

 

This has never happened before and it is driving me crazy and slowing me up.

 

Once I draw something and then select it to move it or scale it or copy it, I keep getting the spinning beach ball wheel. 

Once it finally stops, nothing has happened - no move, no scale, not copy. 

Sometimes I am able to get the object to move - but it moves to a place I was not aiming for.

If I use arrow keys to move an object, it does work just fine, but....

 

I am working on macOS Sierra

version: 10.12.4

processor: 2.3 GHz IntelCore i7

memory: 16 GB

graphic: Intel HD Graphics 4000 1536 MB

 

Affinity Designer 1.5.5

I will attach my file.

 

Let me know if I am missing something - like a setting adjustment.

I'm only asking because this has not happened before and I have never had this problem while I am working with Adobe Illustrator.

 

Many Thanks!

Mario -

 

176 Heydar Aliya Center.afdesign

Share this post


Link to post
Share on other sites

Hi Mario,

Seems you are creating/drawing the objects outside the artboards on the canvas and then dragging them to the artboard layer you want them in the Layers panel. If you do this the objects will disappear because they become clipped - that is they are inside the artboard layer, however their position on canvas isn't inside the artboard boundaries, and so Affinity doesn't display them.

Instead of dragging them in the layers panel, select them on canvas and drag them over the artboard you want on canvas (their layers will then be moved automatically to inside the artboard layer for you).

 

To select these objects change to Outline View Mode (menu View ▸ View Mode ▸ Outline or click the respective icon in the main toolbar), click on them and they should become selected. Then either move their layers to outside the artboard layer they are in, or just move/drag them a little with the mouse (which will automatically change their layers to outside the artboard layer for you). The biggest issue here is that Affinity is not rendering them in outline view mode as well so you are not able to see where they are to be able to select them. I will pass this to the dev team.

 

Thanks for your report.

Share this post


Link to post
Share on other sites

Thanks for getting back to me.

I think understand what I have done wrong.

 

I started a new drawing with a large art board and pasted my drawings onto it - then I created new art boards and resized them and copied and pasted etc. - the problem did not happen in this new drawing.

 

Thanks again,

Mario -

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×