Jump to content
whitehead

[Fixed] AD Brush Preview Persistence (1.5.2.28 & Beta)

Recommended Posts

Just recording this bug on the Windows forum - previously reported over on https://forum.affinity.serif.com/index.php?/topic/26933-brush-cursor-persistence/in Paolo's Mac thread.

 

Show brush previews unchecked/Always show brush crosshair checked in User Prefs.

 

Pixel Persona always defaults to brush preview - crosshair usually appears if round brush selected, crosshair not present if textured brush selected. Behaviour is present on both my main tower PC and my small HP laptop; have not yet been able to remove brush preview and only have crosshair displayed. Unchecking/checking both options in user prefs seems to have no impact either way. R7 Radeon GPU.

 

Thanks!

Share this post


Link to post
Share on other sites

Hi whitehead

 

The brush preview does not change the shape of the cursor, As you move the brush, a preview of the brush with the selected colour is shown underneath the cursor. This disappears if the cursor has been inactive for a second.This is the preview you are turning on and off rather than the shape of the cursor.

 

The brush crosshair is something that affects both apps so I shall make sure this gets logged

 

Cheers


Serif Europe Ltd - Check the latest news at www.affinity.serif.com

Share this post


Link to post
Share on other sites

Weirdly, this isn't the behaviour I see. Regardless of whether 'Show brush previews' is on or off, the brush preview is always on and does not disappear even if the cursor remains static. I'm assuming that the circle shape is also a brush preview, but reflective of the round profile of that brush.

 

Effectively it means it is impossible to paint without the brush preview present, which to all intent behaves as a cursor, although I do understand this isn't the actual cursor as such.

 

I've no idea if I'm alone in experiencing this behaviour, but as someone who only ever paints with crosshairs rather than brush preview (in other applications) it's fairly tricky to use. Wacom drivers etc. are all up to date.

Share this post


Link to post
Share on other sites

Weirdly, this isn't the behaviour I see. Regardless of whether 'Show brush previews' is on or off, the brush preview is always on and does not disappear even if the cursor remains static. I'm assuming that the circle shape is also a brush preview, but reflective of the round profile of that brush.

 

Effectively it means it is impossible to paint without the brush preview present, which to all intent behaves as a cursor, although I do understand this isn't the actual cursor as such.

 

I've no idea if I'm alone in experiencing this behaviour, but as someone who only ever paints with crosshairs rather than brush preview (in other applications) it's fairly tricky to use. Wacom drivers etc. are all up to date.

 

No, you're not alone. As I reported in the other thread, I was unable to turn on the brush crosshair or turn off the brush preview. If I untick the 'Show brush previews' checkbox and tick 'Always show brush crosshair' under 'Preferences > User Interface' in beta build 1.5.3.66, I still get the same (mis)behaviour with the Effects brushes in the Pixel Persona.


Alfred online2long.gif
Affinity Designer/Photo/Publisher 1.7.3.481 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.8.2.174 • Designer for iPad 1.8.2.4 • iPadOS 13.3.1 (iPad Air 2)

Share this post


Link to post
Share on other sites

Just picking up on this with the welcome release of 1.6: although the crosshair on/off does indeed now work, brush preview in pixel persona is still (for me anyway) always locked on, regardless of preference setting. After plugging through the betas for a time, I was really hoping the public release of 1.6 would nail it, but it seems not I'm afraid and I can't see this as being 'fixed' just yet.

It's such a fundamental thing I'm always surprised no-one else seems to comment - in my workflow it's pretty much the only thing that now stops AD from being my daily driver (I find it difficult to paint with preview in the way of the view). I wonder if it may be my system that's throwing something in the way (admittedly it's a pretty basic AMD R7 setup, but powerful enough to handle say CSP with relative ease).

1.6 for Windows is getting so polished now, it's just a bit of a grind not being able to properly break out the DAUB raster brushes and let rip. Or is this something I am only seeing?

Share this post


Link to post
Share on other sites

I'm on Affinity Photo 1.6.1.93 and Affinity Designer 1.6.2.97 for Windows and both has the same problem as described above. It is possible to turn on and of the crosshair but the brush outline is impossible to turn off. It's constant presence - especially when using complex painterly (pixel)brushes makes it difficult and distracting when drawing/painting. Hope this will be corrected soon, as both programs otherwise is really wonderfull to work with!

Share this post


Link to post
Share on other sites

Hi whitehead, ToreB,

This is working correctly on my system (on Windows latest Beta - although the clip below was recorded on a Mac). Just to confirm: the crosshair can now be turned on/off without issues; the brush preview (not outline) is also working correctly and can be enabled/disabled as well. What's "not working" - or rather cannot be turned off - is the outline of the brush (in some cases it's a circle others have an irregular shape). This is not a bug per si. Currently there's no setting to turn the outline of the brush off. See the clip below. If the outline of the brush is what you are having issues with please create a new thread requesting for a setting/option to turn it off as it's a new feature/setting rather than a bug. Am i missing something?

 

brush_outline.thumb.gif.f2dac5de3f64c98a3a51f1bea16c7af1.gif

 

 

ToreB,

Welcome to Affinity Forums :)

Share this post


Link to post
Share on other sites

Thanks for kind and prompt answer MEB. And yes you are absolutely right, it is the brush OUTLINE I can't get to grips with. and which I mistook for brush PREVIEW. So imo there should be three on/off switches in the prefs:

 

1. crosshair

2. brush preview

3. brush outline

 

Well, personally I wouldn't care if the brush outline was removed alltogether. It serves (again at least for me) no purpose, other than distraction.

Should I make a copy of this and place it in a new thread?

Share this post


Link to post
Share on other sites

Ahhh thank you MEB! Yes, as ToreB confirms it is indeed brush outline that is the issue - with round brushes it's probably bearable, but on textured brushes the outline generally obscures where you are trying to work. A further option might also be an option to vary the opacity of the outline for those who use it as part of their workflow.

Anyway, I'll save that for the feature requests...

Share this post


Link to post
Share on other sites

Just installed Windows APhoto update 1.6.3.103, and had hoped that the brush outline issue was solved, the more so, as this forum thread now says “FIXED” in the top.

Bad sadly this is not true - the issue persists! It is very uncomfortable to paint/draw with that outline obscuring what you do. Please make an option to COMPLETELY turn of Brush outlines (wether they are round or represents the texture used) as well as brush previews.

NOTHING, NOTHING whatsoever in ANY mode, other than the little crosshair. Please!! :-)

aphoto1.png

aphoto2.png

Share this post


Link to post
Share on other sites
21 minutes ago, ToreB said:

Just installed Windows APhoto update 1.6.3.103, and had hoped that the brush outline issue was solved, the more so, as this forum thread now says “FIXED” in the top.

Bad sadly this is not true - the issue persists! It is very uncomfortable to paint/draw with that outline obscuring what you do. Please make an option to COMPLETELY turn of Brush outlines (wether they are round or represents the texture used) as well as brush previews.

NOTHING, NOTHING whatsoever in ANY mode, other than the little crosshair. Please!! :-)

 

I think you may have forgotten that this thread is about the brush preview. Please post again to your separate thread about the brush outline to ‘bump’ it to the top of the list.


Alfred online2long.gif
Affinity Designer/Photo/Publisher 1.7.3.481 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.8.2.174 • Designer for iPad 1.8.2.4 • iPadOS 13.3.1 (iPad Air 2)

Share this post


Link to post
Share on other sites

Hi ToreB, 

The Fixed "tag" refers to the original issue posted by @whitehead on the beginning of the thread (this thread was originally a bug report that's why i asked you to to open a new thread in the Feature Requests section to keep things separate). The remove/hide brush outline issue is an improvement request (not a bug) so there's nothing to fix. It now depends on the dev team to consider/add it according to their schedule/plans/constraints.

 

Share this post


Link to post
Share on other sites

Yes, sorry, had forgotten! That's how it goes when you are to quick to dive into the inkwell (as we say in Denmark).

I just keep my fingers crossed.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.