Jump to content
DarkClown

Pressure based rectangle in AD

Recommended Posts

Hi Folks,

I'm struggeling with a simple rectangle that has a pressure based stroke (no fill). I'm getting the following result and can't explain the corners appearing in the middle of the horizontal lines. Is it a bug or am I doing something completely wrong?

 

post-29950-0-91478000-1493206885_thumb.jpg

 

It seems to work OK and as expected with most other shapes ... (Circle, Triangle, Square with rounded corners) - does show the same effect though with the polygon

 

On the other side the Ellipse gets problems with intersecting parts of the curve:

post-29950-0-39863800-1493210736_thumb.jpg

 

Cheers,

Timo

Share this post


Link to post
Share on other sites
Guest

HI DarkClown,

 

For a square or a rectangle you must align the line to the outside to remove this effect.

post-37692-0-82005000-1493230513_thumb.png

Share this post


Link to post
Share on other sites

Thanks reglico, this seems to be a somehow-workaround! ... but it's not the same (rounded corners outside, corner inside). Question remains: bug or feature?
Cheers

Share this post


Link to post
Share on other sites
Guest

I do not know if I really answer your question, but to have the square corners inside and outside, choose "Square" for the corners.

As your screenshot showed rounded corners on the outside, I had reproduced the same drawing.

post-37692-0-36949200-1493233240_thumb.png

Share this post


Link to post
Share on other sites

Hi reglico, thanks again for your answer. I experimented a bit with the settings ... and yes, it is a suitable workaround for the bug. It's all about the "Join" and "Align" settings ...
If "Align Stroke Outside" is active everything works fine! If "Align Stroke Inside" or "Align Stroke Center" are active "Mitre Join" is OK, but "Bevel" and "Round" show this bug.

Since one never knows, can someone from serif confirm this as a "bug" or "undocumented feature"? ;-)

Share this post


Link to post
Share on other sites
Guest

Hi DarkClown, thanks for the feedback.

 

I agree with you, the behavior seems abnormal with some settings and actually looks like a bug.

Regards,

 

Régis

Share this post


Link to post
Share on other sites

Hey DarkClown,

 

Using it as a Mitre Join and possibly upping the Mitre value can improve this. I think it could be done better so I've passed it to development as an improvement. Thanks :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.