GFS

Curve Layer behaviour differs - Node Tool / Ellipse Tool

5 posts in this topic

I'm calling this a bug, because it has really been bugging me.  It's infuriating.  :)

 

When you use the Node/Pen tool to make a path, it creates a layer called Curve.

 

When you use the Ellipse tool and create a shape it makes a layer called Ellipse.  You can click the 'Convert to Curves' button, to change it to curves and it changes the layer name to Curve.

 

So you would expect these two layers to behave the same way.  Well no.

 

For example, trying to use the Pen version as a mask is extremely difficult.  It behaves differently when nested, e.g. you cannot apply Gaussian Blur via fx, to the 'edge' of this mask.  Instead it is applied everywhere (inside as well as the edges).  Again with the Gaussian Blur fx ... if you are using the Pen version as a mask and are using Blend Options ... when you apply Gaussian Blur fx, the image (that you're masking part of) is suddenly filled at 100% ... so it is obstructing/cancelling the Blend Options (presumably because it can't apply the fx to the edge alone).  It also doesn't mask correctly when nested, instead it just blanks out the layer completely.

 

I feel that the behaviour of layers with a single name, should not vary according to which of two tools was used to make it.

 

Took me the last 3 hours to work out what was/is going on.   :blink: Sigh ...


Grumpy, but faithful (watch out all you cats)

Share this post


Link to post
Share on other sites

Hi GFS,

They should both behave the same, do you have a simple file you could attach that shows the two differences at all please? I'm struggling to reproduce from your description - as they say a picture says a thousand words!

Share this post


Link to post
Share on other sites

Hi Sean,

 

I've worked out where I've been going wrong.  When you make a shape with the Rectangle Tool, it has a colour fill.  When you make a shape with the Pen Tool, it has no fill.  I'm coming from an app that isn't PS and doesn't work with black/white fills, so I wasn't expecting this differing behaviour.

 

This is further confused by the 2 nesting positions (I can find no explanation in the Help, about how these are supposed to work ... can you tell me where I can find that?).  When I nest a Pixel layer into the 2nd nested position of a Pen Tool shape, it works as a mask in the way I want ... but the shape still has no Fill!!

 

Can I make a suggestion, that when a shape which has no Fill, is dragged into a nested position on a pixel layer ... it is automatically filled with white?  I can't see why anyone would want to nest a shape for any purpose other than to use it as a mask, so it would be a logical job for the Assistant.  This would also mean that both the Rectangle Tool shapes and the Pen Tool shapes work identically when used as nested masks.


Grumpy, but faithful (watch out all you cats)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now