Jump to content
cramm

[Fixed] Badly rasterized images on Export

Recommended Posts

I run Designer 1.5.2.58 and I have an issue when exporting to any rasterized file format be it PNG, JPG, ...

Changing the resampling method does have a slight impact on quality, but it is never as it should be.

 

See the attached screenshot: left is how Designer displays the document on my screen at 100%, right is a PNG export with PNG-24 preset selected at 100%.

 

The shadow doesn't render correctly and the fonts render very badly in the PNG.

 

Thanks for helping with this!

post-57312-0-60925800-1492724082_thumb.png

Share this post


Link to post
Share on other sites

Hi cramm,

Welcome to Affinity Forums :)

Something weird is happening there. The export should match what you see in Affinity Designer (at 100% zoom).

Can you please upload the .afdesign file using this link so we can take a look at what's going on? Don't forget to add you forum's username to the file name.

All files will be deleted after being checked.

Share this post


Link to post
Share on other sites

Sorry, I missed your reply, probably because the email went to my spam folder. I have now uploaded the original file using the link above.

Thanks for your help!

I am using a Microsoft Surface Book with Windows 10.

Share this post


Link to post
Share on other sites

Just tried version 1.5.3.69 with the file above. The issue is still there. Just uploaded a PNG export from 1.5.3.of the top part of the file to the dropbox link above as well.

 

Something I also noted: there seems to be a similar issue with exports from Affinity Photo. May be the problem is a wrong / outdated grafics dll somewhere? Strange though, because its a new machine and up to date Windows 10. I do however have an installation of Adobe creative Suite CS 2 on the same machine. Should not have an impact an Affinity though, since I have installed the Affinity products and their updates *after* the Adobe stuff.

The export to PSD works fine by the way. JPG and PNG (have not tested other options) have the issue described.

Share this post


Link to post
Share on other sites

Something I noted today: the problem only occurs if you do not export the entire document but a selection with background.
The entire document export looks perfect, the selction export has the described problem.

Share this post


Link to post
Share on other sites

Hi cramm

 

I'm able to reproduce this now. It does seem like it's only when using the selection with background option and you have multiple objects selected. I'll make sure this gets passed on

 

Cheers


Serif Europe Ltd - Check the latest news at www.affinity.serif.com

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×