Jump to content

Recommended Posts

Hello, Affinity forum members!

 

I'm using Affinity Photo mainly to stitch and edit panoramas, usually 4k, but up to 8k.

For this I'm using photos I made with my Sony Xperia Z3, and in-game Screenshots. But last ones sometimes go horribly wrong.

 

Currently, I'm trying to stitch a Panorama with screenshots of an in-game sunset, and they looked pretty promising, but Photo crashes every time I tried to stitch them. I tried to leave some Photos out, restart my PC, restart the Programm, stitch another one, which works fine btw, and it still just doesn't want to stitch them.

As this is not the first time I experience crashing with Photo, and although I'm reporting it always and leaving always my email, I never got a response.

 

-- I'm from Germany, so the errors are not translated into English, but the error codes are in the report, so hat shouldn't be a big issue --

 

So today a bit extended bug report:

It alway goes like this:

1. Choose photos

2. click on stitch

3. stitch dialogue shows the loading symbol

4. loads a few seconds

5. stops loading, shows the error code 0x80004003

6. with a click on "OK" the error and Photo are closing

 

Sadly, I've got no clue what to do, so a response would really help me a lot.

 

-- PC Specs --

Windows 10 Pro (64 Bit)

i5-4670

8GB DDR3 clocked at 1866Mhz

MSI Radeon R9 380 4GB, clocked at 1000Mhz

 

-- Photos Used --

.png format

4096x2160

8.85MPX

all photos are attached.

 

have a nice day,

Leo

post-57209-0-88916300-1492627755_thumb.png

post-57209-0-45014800-1492627764_thumb.png

post-57209-0-38196900-1492627771_thumb.png

post-57209-0-17147300-1492627777_thumb.png

post-57209-0-73360400-1492627782_thumb.png

post-57209-0-17117800-1492627792_thumb.png

post-57209-0-58699500-1492627802_thumb.png

post-57209-0-46551600-1492627812_thumb.png

post-57209-0-74998300-1492627818_thumb.png

post-57209-0-31593300-1492627823_thumb.png

post-57209-0-70585900-1492627841_thumb.png

post-57209-0-22121400-1492627846_thumb.png

post-57209-0-31067700-1492627853_thumb.png

post-57209-0-07344700-1492627862_thumb.png

post-57209-0-27050900-1492627868_thumb.png

post-57209-0-58107300-1492627872_thumb.png

post-57209-0-07913900-1492627877_thumb.png

post-57209-0-26442400-1492627881_thumb.png

Share this post


Link to post
Share on other sites

In fact it looks like this has already been reported and fixed in the latest beta. I believe it occurred because there was a lot of duplicated areas in the images. If you head over to the beta forum, you should see a post pinned at the top with the latest build. You can download and install this alongside the non beta build and work with the two at the same time. Please note that ss this is a beta release, it is considered to be not suitable for production use. This means that you should not attempt to use it for commercial purposes or for any other activity that you may be adversely affected by the application failing.

Share this post


Link to post
Share on other sites

In fact it looks like this has already been reported and fixed in the latest beta. I believe it occurred because there was a lot of duplicated areas in the images. If you head over to the beta forum, you should see a post pinned at the top with the latest build. You can download and install this alongside the non beta build and work with the two at the same time. Please note that ss this is a beta release, it is considered to be not suitable for production use. This means that you should not attempt to use it for commercial purposes or for any other activity that you may be adversely affected by the application failing.

 

Thank you, Sean!

BTW: Is there a time plan for small stable updates, or do they get released just as soon as they are available?

Share this post


Link to post
Share on other sites

Unfortunately we don't have an exact time plan, however when a fix is made by developers it isn't immediately made available. We generally do 'cycles' of beta updates until we get a build we are happy to submit to the Apple App Store and also a build we are happy to release to the wider public.

Share this post


Link to post
Share on other sites

Could we go back to the last stable version that did work with Panorama?

I have the newest Mac OS 10.12.4, and it will crash every time when trying to render a Panorama.

Share this post


Link to post
Share on other sites

Could we go back to the last stable version that did work with Panorama?

I have the newest Mac OS 10.12.4, and it will crash every time when trying to render a Panorama.

Idk how it is with the Mac Version of Photo, but this problem exist since the first windows beta.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.