Jump to content
Sign in to follow this  
Rob123456789

Rectangular Marquee Tool - marching ants not showing, no selection made

Recommended Posts

I have an intermittent problem, where I cannot make a selection on my image using any of the selection tools (e.g. Rectangular Selection, Magic Wand, Freeform Selection). I am on a "Pixel" layer, and not an "Image" layer. I can select the tool, and draw my selection, and while I am drawing the selection I can see the marching ants, however when I let go of the mouse, there is no selection. I have to save my document and close Affinity Photo then r-open the file.

 

I have checked the obvious things that I can think of, including:

* Have I selected the "Pixel" layer (yes - and this is the only layer in my file)

* Have I tried toggling the menu option View > Show Pixel Selection (yes, several times)

* Is my selection mode set to "New" ot "Add", and not "Subtract" or "Intersect" (yes, I always set it to "New")

 

I can't think of anything else it might be. I am running version 1.5.1.54 on Windows 10 Home 64bit. My compter is well above the minimum reccommended spec.

Share this post


Link to post
Share on other sites

Can you please try to reset the app and check if the problem persists please? To do it press and hold CTRL while launching the app then select Clear from the dialog that will open. Let me know if you still have the issue after the reset.

 

It seems I have a similar problem. I cannot select any pixels with the marquee tool.

What works, though, is e.g. "Select all" from the menu or "Select color range".

 

I tried to reset AP beta by holding down the CTRL key but it does not give me the option to clear anything.

 

d.


Affinity Designer 1.7.1.404 (beta 1.7.1.404) - Affinity Photo 1.7.1.404 (beta 1.7.1.404) - Affinity Publisher 1.7.1.404 - Affinity Designer for iPad 1.7.0.7 - Affinity Photo for iPad 1.6.8.77

Windows 10 (1809) 64-bit - Core i7 - 16GB - Intel HD Graphics 4600 & NVIDIA GeForce GTX 960M
iPad pro 9.7" + Apple Pencil

Share this post


Link to post
Share on other sites

I tried to reset AP beta by holding down the CTRL key but it does not give me the option to clear anything.

 

You need to press the Ctrl/Strg key, keep it held down while you launch the program and continue to hold it down (for quite a long time here!) until the Clear User Data dialog appears.


Alfred online2long.gif
Affinity Designer 1.7.0.367 • Affinity Photo 1.7.0.367 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.7.0.135 • Affinity Designer for iPad 1.7.0.9 • iOS 12.3.1 (iPad Air 2)

Share this post


Link to post
Share on other sites

You need to press the Ctrl/Strg key, keep it held down while you launch the program and continue to hold it down (for quite a long time here!) until the Clear User Data dialog appears.

 

Thanks Alfred, holding down the CTRL key longer did the trick. I was not aware of that.

 

Now selecting with the marquee tool does works again  :)

 

d.


Affinity Designer 1.7.1.404 (beta 1.7.1.404) - Affinity Photo 1.7.1.404 (beta 1.7.1.404) - Affinity Publisher 1.7.1.404 - Affinity Designer for iPad 1.7.0.7 - Affinity Photo for iPad 1.6.8.77

Windows 10 (1809) 64-bit - Core i7 - 16GB - Intel HD Graphics 4600 & NVIDIA GeForce GTX 960M
iPad pro 9.7" + Apple Pencil

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×