Jump to content
WalterBeiter

vector shape rasterizes on export when filled with a gradient

Recommended Posts

I've made a nice world map with AD and applied a gradient to it. When I export this as a pdf file, it will be rasterized. However, other shapes on that world map such as an arrow (line) won't be rasterized on export. 

I changed the filling to a solid color and exported again. 

Now my map won't be rasterized anymore, but I've lost my gradient.

How can I export a shape filled with a gradient without rasterizing it?

 

 

Share this post


Link to post
Share on other sites

Which PDF export preset are you using? If you click the More button and check Allow advanced features it should export as vectors, unless there's other features forcing the rasterisation (some Blend modes, Layers Effects etc).

 

Hi there,

 

I seem to be having the same problem. I've placed an .eps file of a simple gradient logo into the document, however when I export to PDF (print), it does one of two things depending on what I choose in the advanced settings:

 

1.  If I choose 'Rasterize: Nothing' from the dropdown menu, I get my clean vector lines but no gradient, and;

2.  If I choose to leave the advanced settings as is, I keep the gradient but the logo becomes pixelated because it was rasterized in the export process.

 

I ensured both times that 'Allow advanced features' was checked. Any other ideas on how I can export this entire file while still keeping the vector gradient?

 

Thank you!

Share this post


Link to post
Share on other sites

Ok, it seems that there is a problem with the gradients. I still have that problem in a completely different document. 

The gradients will get rasterized during export. Is there any fix to this? 

This is not true for all gradients of my document. But there is one which will get rasterized. 

Share this post


Link to post
Share on other sites

ok it seems that this was NOT because of the gradient, but because of an underlying shape. I had to delete that particular shape (which had plain white as a filling) and redraw it. Now it works.

Share this post


Link to post
Share on other sites

After trying a few combinations, it seems it is possible. If we turn off embed profiles option, in the "more" window of the PDF export, we can stop gradients from rasterising. However, FX, Opacity, Adjustments and some cases even grouping of curves cause rasterization.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×