Jump to content
Mark_A

.afphoto file with single pixel layer, Affinity photo unable to edit it.

Recommended Posts

Occasionally, using Affinity Photo 1.5.2, an .aphoto file ceases to respond to edits. I don't have a way to reproduce this reliably yet, but the attached file's a sample that shows the problem.

(Affinity Designer 1.5.5 isn't happy to work with that file either.)

 

In this case, on the original image, I was using the inpainting tool again and again, and at some point the edits ceased to work.

 

If the pixel layer is duplicated using command + 'J', the new layer contains ... something ... but not the image from the duplicated layer.

 

'Edit/copy from the pixel layer' and then 'File/New from clipboard' shows unhappy results too.

 

Apologies in advance if this is me missing something obvious.

 

Mark

 

 

test-affinity-editfail-2.afphoto

Share this post


Link to post
Share on other sites

You have a hidden pixel selection of 2px X 10px. 

 

CTRL D will clear the selection and the document should then function as normal

 

This "bug" has been reported before.


Due to the fact that Boris Johnson is now our Prime Minister, punctuation, spelling and grammar will never be worried about ever again.  We now have far bigger problems to be concerned about.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.