Jump to content
triforcesolutions

AFFINITY DESIGNER: Save failede because access to the file was lost

Recommended Posts

Hi there,
I was looking for similiar problem on this forum without success.
What I found was this topic: https://forum.affinity.serif.com/index.php?/topic/29894-save-failed-because-access-to-the-file-was-lost-document-must-now-be-closed/
related to files that are stored on external media.

 

My problem description:
I am wornking on Windows 7 64, what I do is filling template document with some data.
My workflow is as follow: every file has its own name, starting with serial number increased by one. When I get new document to fill - I am opening last one and after editing everything what needs to be edited, I am saving file as with number increased by one. Then I am exporting two files - jpg and pdf, then save and quit. Or - if there are more documents - I repeat previously described steps.

 

Yesterday I had error message described in topic name.
What is interesting - even if I change name in "save as" step to "new name" - error message is reporting that "Failed to save document "old name" Save failed because access to the file was lost."

I tried to: change location, change name - no effect.
File is being saved on local drive, no data from external media is linked in file.

 

I have two AD versions installed (due to reported e.g. by me Polish diacritics problems error) - beta and latest stable. The same problem is on both versions.
 

File can be exported to given file type, but this is no solution for me. There are lots of situation, when I need to change those documents on the fly, and this error forces me to create new one every time from the scratch.

I hope you will be able to provide me help,

regards.

 

[edit]

Problem appears with every file created till about yesterday - there are like more than hundred of them.
Also when creating new document and saving and closing it, when document is opened and option "save history with document" is enabled - also this error appears.

What I forget to mention is that this option is enabled in those template files, but disabling it, restarting AD and opening those files changes nothing. Problem still appears.
It looks like this problem appears with every file that I am opening and trying to save as with different name. If I do not try to save as with different name I can save opened file.

Share this post


Link to post
Share on other sites

@Wiredframe

Thanks for your response. Like I wrote before:

 

File is being saved on local drive, no data from external media is linked in file.

 

All data is stored on local drive, links are from local drive, no data is from ext. drives or network drives.

 

This is very frustrating for me, I thought that I will ANY help here, and right now software is quite useless for main purpose why it was bought.

Share this post


Link to post
Share on other sites

Hi triforcesolutions,

 

Could you please post us a template file that is going wrong for you.

 

Also could you confirm the folder names you are saving to?

 

What anti virus software are you using?

 

and finally have you tried checking your disk for errors?


Living the Dream since 1964 - about 25 years left

Share this post


Link to post
Share on other sites

@pauls folder where I am saving is as follows: X:\certyfikaty
When it comes to file - I can send you one of them, but in private message, this is file that I don't want to be available online.
But honestly I don't know if this is necessary - when I am opening previously saved file (on any of my disks and any of partitions) and I want to save this file with new name - previousle described error message appears. Not only with those templates, but with website projects that I am making right now etc. I can't save daily sub version of file.

 

Antivirus is AVG, firewall is Zone Alarm pro, disks are in good condition, system ssd, cache ssd and data hdd - all are going well.

 

Is reinstalling AD any option? I will try this and will let you know.

Share this post


Link to post
Share on other sites

@pauls Thank you for your help, like I wrote to you in pm it looks like the reason of saving problems was hdd failure (software that I am using regularly didn't found any errors, but thanks to your post I tried another one - with critical condition result). So this topis may be marked as solved.
Also - I would like to thank you, pauls, because thanks to this topic I had time to backup all data from this hdd and I didn't end with important data los.

 

Thanks for help,

regards.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×