Jump to content
creativelogic

Dual monitor with different scaling, tool cursor image huge

Recommended Posts

System information:


  • Operating system: Windows 10 (Anniversary Update)
  • Dual monitor setup
  • One monitor is a 4K screen (3840 x 2160) set to 250% scaling
  • The other monitor is (1920 x 1080) set to 100% scaling
  • Affinity Photo Version: 1.5.1.54

 


Steps to reproduce:


  • Simply open Affinity Photo in the 100% scaled monitor. 
  • Select a tool (other than Move Tool), and move cursor over your image, it will be very large and pixelate (see screenshot with View Tool, large hand icon)

 


Other Notes:


  • If you move Affinity back to the high DPI display, tool cursor is perfect there.
  • Move Tool, which seems to just use default cursor does not have this issue.

 


Otherwise, I am super impressed how well Affinity works already on High DPI displays and multi monitors, it's not yet perfect, but far far better than a large number of Windows programs and competing photo editing apps. Well done!!


post-55942-0-95631900-1491273048_thumb.jpg

Share this post


Link to post
Share on other sites

Hi creativelogic

 

The large cursors (or small depending on what you have selected as your main monitor) is a known issue. I believe this may be an artefact of using WPF to scale the app, but the team are aware of this.

 

Cheers


Serif Europe Ltd - Check the latest news at www.affinity.serif.com

Share this post


Link to post
Share on other sites

I have the exact same issue. Has anyone been able to find a fix?

 

I'm using Win10 with 2 monitors (2560x1440 and 1920x1080). I even tried it on my 4k TV (250% scale) and same problem.

I played with the system cursor size and no changes at all. 

Share this post


Link to post
Share on other sites

I am having the same issue as well.   Windows 10 with a 4k laptop display (200%) and an external display 3440x1440 (100%).

Share this post


Link to post
Share on other sites

Hello, I'm new with Affinity Photo. With my Surface Book 2 i have the same "Bug". Display 1 with 3000x2000 (200%), and external Display 1920x1080 (100%).

Affinity Photo Version 1.6.5.135.

As a new Affinity Photo user that comes from Photoshop, it's a bit disappointing because this bug has been exists for a long time and hasn't been fixed yet.

 

001.PNG

002.PNG

003.png

Share this post


Link to post
Share on other sites

The same problem still exists with Affinity Photo 1.7 under Windows 10 1903 with Surface Book 2 (200%) and external monitor (100%). I'm really disappointed that this bug still hasn't been fixed after over 2 years. :41_pensive:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×