Jump to content
Maultierhirsch

Focus Stacking, source pictures disappearing

Recommended Posts

Situation: I stacked several photos using the focus stacking feature. The sources window appeared correctly with all the stacked result plus the source photos. I then opened another photo (.nef) for editing in affinity photo out of xnview MP. The photo loaded and then I chose to swich back to my stacked photo. The stacked photo showed up but the sources window was empty.

 

Is this a wanted behavior? If so why?

Is there a way to get the content of the sources window back?

 

Thanks in advance

Matt


Win7 Pro 64 Bit, Intel Core i5-3550 (4x 3,3 GHz), 32GB Ram

Share this post


Link to post
Share on other sites

Hi Matt

 

The sources panel is linked to the clone tool. When you switch away from the clone tool the panel de-populates, however when you switch back to the tool the panel should populate again

 

Cheers


Serif Europe Ltd - Check the latest news at www.affinity.serif.com

Share this post


Link to post
Share on other sites

I will confirm this behaviour - once closed Sources window - goodbye sources no matter of clone tool. (1.52.69)
 

Latest beta ("81") is a little better - sources can be populated again by selecting a clone tool but only in a current session - if a work in progress is saved, Photo closed and then started and continued later - again no sources in a source window.

 

 

 

 

Share this post


Link to post
Share on other sites

I just tried it out with V. 1.52.69: My sources tab/window reappreares when I switch back to the clone tool - even after applying some changes to the image (but I only tried the brush). But like kbro says, after saving and reopening the file (affinity file format) the sources are gone, which is really impractical.


Win7 Pro 64 Bit, Intel Core i5-3550 (4x 3,3 GHz), 32GB Ram

Share this post


Link to post
Share on other sites

This problem is at least several months old, found this:

 

but I have to test it on my other Win10 PC config (previous report was for Win7)

Share this post


Link to post
Share on other sites

I want to report that this happens on Mac too. I've noticed that before, but today I'm sure that's what happened.

Steps to reproduce:

  1. Launch Affinity Photo.
  2. File -> "New Focus Merge"
  3. Select two photographs and click "OK". Wait for focus merge to finish.
  4. "Sources" panel now shows three items: "Focus merged image", and two source files. "Toggle source preview" is deselected, if that matters.
  5. Do nothing to the image, just save it to disk.
  6. Close file.
  7. Open it again.
  8. "Sources" panel is now empty.

Affinity Photo 1.6.6, macOS High Sierra 10.13.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.