Jump to content
opeter

Affinity Designer -> PDF Export, text gets converted to curves

Recommended Posts

Hello.

 

Sorry to bother, but I have a problem with Affinity Designer for Windows (right now I don't have a Mac at my hand, so cannot replicate the problem on there).

 

Whenever I try to use some TTF fonts in a document and try to export it to PDF, these texts gets outlined/converted to curves.

And I don't know, why. What am I doing wrong?

 

These fonts are from the Softmaker Megafonts XXL fonts library and they did work in the past without problems in other graphical application, so I don't understand why they doesn't work in Affinity Designer.

 

Here are my tryed settings (but whatever I do, it is the same, the texts get converted to curves):

WPkFKU1.jpg

 

I tryed to make a test file and uploaded some of these fonts.

 

Here is the test document:

test.afdesign

 

Here is the PDF, try to select both text with the selection cursor in Adobe Reader or similar PDF reading apps:

test.pdf

 

Here are two fonts:

fonts.zip

 

Does someone have any idea? Thanks in advance.

Share this post


Link to post
Share on other sites

Hi Opeter,

Can you verify that you are using Affinity Designer version 1.5.2.58 please? I've tried it myself in that build and it exports correctly using PDF (for web) and the text is selectable, I also noticed my Estimated File Size was display as 7.43kb. Could you try and export it using the Designer Beta please?

 

Share this post


Link to post
Share on other sites

Hi Sean P,

I am using version 1.5.2.58.

 

Here is a screenshot:
DXyzM3k.jpg

 

Will try to use the Beta version and report back.

Share this post


Link to post
Share on other sites

Sean P, I just tried the Beta version and I get the same result:

 

2vlc3iZ.jpg

 

F7BcV1z.jpg

 

Look at the attachement (pdf).

For whatever reason, the text gets converted to curves/outlined.

 

I am using the default settings for pdf export (in this case PDF export for Web):

3des3rx.jpg

 

vmG56dl.jpg

 

Thanks.

test.pdf

Share this post


Link to post
Share on other sites

I'm getting selectable text in my PDF file here. The only slight oddity is that the space in my test string 'PDF test' was achieved in the Balloon text by a Tracking value of 250 per mille instead of a space character. (As expected since the Balloon font has no lowercase glyphs, the lowercase letters in the test string were rendered as Arial when I opened the PDF in AD.)


Alfred online2long.gif
Affinity Designer 1.7.0.367 • Affinity Photo 1.7.0.367 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.7.0.135 • Affinity Designer for iPad 1.7.0.9 • iOS 12.3.1 (iPad Air 2)

Share this post


Link to post
Share on other sites

Hello, Alfred.

Thank you for your reply.

 

Than it seems, that the problem is something with my computer/Windows installation (I am using Windows 8.1 64-bit)...

 

Ouch! That means, I have to reformat and reinstall one day the whole system.

Anyway, I will try to do that in the comming month (april) and than I will report back.

 

OK, thanks for your help guys!

Share this post


Link to post
Share on other sites

Having the same problem in the latest stable version 1.6.4.104.

The text is scalable bit is not selectable no matter which options I select. Tried to Embed all the fonts and same result.

Of course this happens with custom fonts (Open Sans in my case). Did someone find a solution? Thanks!


Check out my awesome Windows 10 Themes!

Share this post


Link to post
Share on other sites

Affinity Designer/Photo exports PDF with embedded fonts only with system installed fonts. It does detects fonts activated through programs like FontBase, NexusFont, etc. but unfortunately it doesn't embed those fonts with the document.

The workaround will be to install those fonts directly on the system, and then export the PDF with embed fonts feature enabled.

This has been worked for me so far!
Hope it might help someone.

 

Share this post


Link to post
Share on other sites

Thank you  @Vishnu Raghav so much, this is nice trick, it working!!

I didn't try but do you think it would work if only I install this font on pc  without having a need to open this file again in affinity and export it?

In other word would this trick work without exporting again after installing font?

If that is working than this is not a bug, but if you still need to export file again, than that would be so irritating.

Share this post


Link to post
Share on other sites
34 minutes ago, SaulGoodman said:

In other word would this trick work without exporting again after installing font?

You need to export after installing the font. There’s no way the app can embed a font which isn’t available at export time.


Alfred online2long.gif
Affinity Designer 1.7.0.367 • Affinity Photo 1.7.0.367 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.7.0.135 • Affinity Designer for iPad 1.7.0.9 • iOS 12.3.1 (iPad Air 2)

Share this post


Link to post
Share on other sites

Adobe Illustrator don't need this when working with fontbase, so I think Affinity can make this possible also. If I need to install every single font I use in some project then program like fontbase is useless, but that would not be a problem if anyone can install 2k of fonts and boot the OS. I tried it once and I needed to reinstall my OS.

So, for me this is urgent.

Share this post


Link to post
Share on other sites

Unfortunately I'm still unable to reproduce this using FontExpert. Could someone who uses either this or FontBase just do a quick video on how you're setting these apps up and activating a font.

See screenshot to how I have FontExpert set up. I have created a folder and placed all the fonts inside that. I then added that as a folder under 'My Collections' inside the Font Tab. I then clicked either Install Font or Temporarily Activate Font to use it. The font then appears in Affinity, and on export I use PDF (For Web) as it as Embed Subset Fonts enabled. However the font is then correctly subsetted inside the PDF (see sample PDFs).

FontExpert.png

test.pdf

test2.pdf

Share this post


Link to post
Share on other sites

@Sean P When installing the fonts it's important to have this option on: "Leave files at their current location" because that's the idea of using a font manager, to keep the files in their location not to copy them to the Fonts folder.

Also don't add the font to the Library. Use the Folders tab because again, this keeps the font files in their place on the hard drive.
image.png.068da9bc5af18914b08d852f7a036195.png

From your screenshot you might have selected the other option: "Copy files to Fonts folder" because the installed fonts are not highlighted in Green.

I've also attached my test files (the AD file and the exported PDF). As you can see, you won't be able to select the text in the PDF and if you open it in AD the text will be converted to shapes.

Instead if I install the Fonts using the "Copy files to Fonts folder" option in FontExpert, then of course the PDF will be exported properly with the embedded fonts, just like someone else mentioned above.

fonts_test.afdesign

fonts_test.pdf


Check out my awesome Windows 10 Themes!

Share this post


Link to post
Share on other sites

Hi Christian,

Thanks for that! I've reproduced it with your file, and what is interesting is that only a couple of fonts are doing it for me (out of the handful I tried). OpenSans from your file, and also found Antonio doing it for me, where as quite a few others were fine. Even ensuring I was installing using 'Leave files at their current location' - see screenshot.

Would you be able to try the contents of the attached zip file please? 3 out of the 4 fonts on the AFDesign file worked, whereas the last one didn't! I'd be interested to know if is limited to specific fonts, or their is something I'm still missing!

Thanks

FontExpert.png

Font Test.zip

Share this post


Link to post
Share on other sites
On 9/23/2018 at 9:21 AM, Vishnu Raghav said:

The workaround will be to install those fonts directly on the system, and then export the PDF with embed fonts feature enabled.

Thank you Vishnu, after a year and half that is the only solution, that works for me!
I is a bit akward, but it does the job.

Thanks once again. :)

Share this post


Link to post
Share on other sites

Well, I am not happy with this solution for two reasons, Font expert cost money and I believe Windows OS still booting your fonts when booting OS no matter if you don't move your fonts in font folder.

Fontbase is excellent, it's free and you don't need to install fonts, just run them before opening Affinity. I tried working like that in Adobe Illustrator and fonts are selectable after exporting in pdf, so this must be a bug or not developed feature which I really think is important. If I am the only one who see this as a problem than they won't do anything I believe.

Also I don't know why Affinity don't have something like font base, just option to select one folder in settings, one folder with with all fonts form which he can read fonts but without installing them. That simple solution would be so useful..

Share this post


Link to post
Share on other sites

Hey @Sean P

Sorry for the late reply!

I've tested the file you attached and I'm getting the same result: all the fonts embed correctly except for Antonio.
So it seems there must be something specific about these fonts. I've tried to find some difference between Antonio and the others but can't seem to find anything that makes sense so I'm just stuck.

Maybe if you could contact some fonts foundry or someone that makes fonts which might give you a lead in solving this problem.

Let me know if there's anything I can help with :)


Check out my awesome Windows 10 Themes!

Share this post


Link to post
Share on other sites

Exported as pdf x-4 and no problem here to select temp activated fonts(FontExpert2018)
Tested with the Antonio font and the testfont file by Sean P

 

Font test.pdf

Antonio.pdf


-------------------------------------------------------------------------------------------------------------------------------
Win10(1809)Home / Photo / Designer / Publisher & latest (beta) versions

Share this post


Link to post
Share on other sites
56 minutes ago, haakoo said:

Exported as pdf x-4 and no problem here to select temp activated fonts(FontExpert2018)
Tested with the Antonio font and the testfont file by Sean P

 

Font test.pdf

Antonio.pdf

I've tested the export using all the PDF options and the result is always the same (specific fonts like Antonio doesn't get embedded unless I install the font in the System folder).

Can you please share the AFD file as well? I'm using FontExpert2016 here and maybe that could be an issue?


Check out my awesome Windows 10 Themes!

Share this post


Link to post
Share on other sites

Sorry,only tested it quickly and I don't have the afdesign file with the Antonio font saved

 


-------------------------------------------------------------------------------------------------------------------------------
Win10(1809)Home / Photo / Designer / Publisher & latest (beta) versions

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×