Jump to content
kcx

Grouping layers with constraints

Recommended Posts

The background:

 

Webpage with footer "attached" to bottom of the page using constraints.

All elements of footer are not groupped.

Some of the elements are attached to page using constraints.

 

 

The problem:

 

When I select layers and want to goup them together they disapear. They don't change positions. They just disapear. When I click on the element in layers palette, handlers appear where they should, but there is nothing inside them.

 

I've found workaround, creating group from any object without constaints, and then manually adding layers by draging them onto the group created in layers palette. It works, but I think it would be easier to just to hit CMD+G :)

 

 

best regards from Poland

 

 

Cezary Kaczmarek

 

 

 

 

post-54882-0-86126700-1490180296_thumb.png

post-54882-0-56746000-1490180329_thumb.png

post-54882-0-69135200-1490180362_thumb.png

Share this post


Link to post
Share on other sites

The file is 250MB big (I dont know why) It was a part of bigger project. I've isolatad the part where was the "bug" but the file doesn't want be smaller. History is cleaned. I attached another file but behavior is the same.

constraints2_report.afdesign

Share this post


Link to post
Share on other sites

By the way... Similar behavior I've noticed, when I tried to make a symbol form several objects, where some of them were photos cropped to circle by curve layer. Suddenly the pictures disapear in symbol inspector and all other places. It is quite frustrating. The pictures don't appear on the screen, but when I click one of them on layers list,  handles appear where they should, but with nothing inside the space between them - just pure Curve which was used as a "clipping mask". The pictures are still on layers list, with proper icons, but are not visible. I'm not sure when it happens, what you should do to recreate it.... I will post a message when I will be able to recreate it or notice when it happens.

Share this post


Link to post
Share on other sites

Hi kcx,

Thanks for the files - easy to reproduce with those. I'll get it passed on! It sounds like the problem with the Symbols could be related to the same issue, however if you do have a file when you recreate it that would be most useful. Thanks again for attaching the files!

Share this post


Link to post
Share on other sites

.... aaaaaaaand YES!!! I got it!!! I managed to make pictures disapear from clipping masks. This time even handlers didn't show up. The image is still on the layer list, but is invisible. I found out it happens, when I move one of the artboards on screen to the side far enough to make screan pan to the side. That was the moment, images disapeared. And what's more I have it recorded :) with QT. The file is over 400mb so I've uploaded it to dropbox:https://www.dropbox.com/s/3rcqk5d8t8z556z/images.disapear.mov?dl=0

Share this post


Link to post
Share on other sites

Thanks for the video! I've had a go myself on a new document, by creating some symbols with nested images and moving artboards and such like but cannot reproduce it. Are you able to share your document from the video at all please? If you do not wish to share the link publicly then please PM me with it.

Share this post


Link to post
Share on other sites

I'm looking forward... For me symbols are the greatest, "must-have" tools for webdesign :) 

Share this post


Link to post
Share on other sites

Hi,

I encountered similar behaviour - when I group some layers the group disappears from the viewport. I did find it though way outside of the art board. When I moved it back to place and ungrouped, the released layers jumped away again, this time in the opposite direction. Seems to me, that the layers keep some kind of coordinates, that become relative to the group container when you group them. Also I realised, that  the groups with this behaviour are automatically named "Constraints group" in the layer panel, not just "Group" as usual. I didnt find anything about Constraints groups in the help topics. Is this a standard feature?

Share this post


Link to post
Share on other sites

Hi Dorotea,

Welcome to Affinity Forums :)

Constraints as the name implied lets you apply constrains to objects to define their behaviour when placed inside a container (usually an artboard) so they adapt dynamically to the width/heigh changes of the container. They are mostly used when you need to layout/design apps/web apps where the contents (buttons, text, images) need to adapt to various screen sizes for example. When you ungroup a constraints group (which serves as the container for those objects), their behaviour will start to act in relation to their new parent container (which may be the document canvas itself) thus the unexpected jumps of the objects to other places.

 

For more info about constraints check the following video tutorials: 

Constraints: Overview

- Constraints: Worked Example for Web Design

 

You can find additional info on the help file here:

Affinity Designer Help ▸ Design Aids ▸ Constraints

Affinity Designer Help ▸ Workspace ▸ Panels ▸ Constraints panel

Share this post


Link to post
Share on other sites

Hi and thanks!

I kind of figured out that the jumping objects somehow relates to the constraints feature (which am aware of), but can you please help me figure out how to prevent objects from jumping out of the layout when I group them? Thanks

Share this post


Link to post
Share on other sites

Hi and thanks!

I kind of figured out that the jumping objects somehow relates to the constraints feature (which am aware of), but can you please help me figure out how to prevent objects from jumping out of the layout when I group them? Thanks

Hello,

is my question unclear or difficult to answer? Or isn't this forum actually ment for supporting users, but rather for promoting your product. What a disappointment!

Share this post


Link to post
Share on other sites

Hi Dorotea,

I'm sorry for the delay getting back to you. Sometimes a post or thread goes unnoticed in the middle of all activity. Please accept my apologies.

Regarding your question, as far as i know the only way to prevent that behaviour is removing the constraints prior to grouping/ungrouping. Apparently there's no easy way to do it quickly for a group of selected objects. I will talk/pass this to the dev team. This behaviour however may be due to a bug. Can you please upload your .afdesign file (you can delete all objects except the ones you want to group that lead to the undesired behaviour) using this link so i can check it and add to the report? Don't forget to add your forum username (@Dorotea) to the file name. Thanks

Share this post


Link to post
Share on other sites

Erm, yes, a fat +1 from me on this one. I've been struggling enormously with groups and constraints, too. These random relocations upon grouping/ungrouping are a total efficiency killer. Please, please, fix this.

 

@MEB: Do you still need a sample file or have you been able to replicate the problem?

 

[edit] Gaah, I didn't notice this thread is in Bugs on Mac section. However, this happens on Windows (10, 64 bit) as well.

 

I will post another bug I discovered today, unless it's been already reported.

 

cheers

Matt

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.