• Announcements

    • Patrick Connor

      Forum Upgrade   07/12/2017

      Welcome to the upgraded Affinity Forums. This change will allow us to add more features and block spam better. If you have any problems using these forums as a result of the upgrade, please post in the the similarly named News forum thread.
phoenixart

Consistent bug on a curve adjustment layer

5 posts in this topic

Hi there,

 

I'm working on a file, it is 1.3 GB.

I'm on Windows 7 Sp1, with 32gb of Ram and Nvidia Quadro K4000.

 

My latest layer in the stack is causing a consistent crash.

I'm adding a curve adjustment and right after I add the curve, Affinity Photo crashes.

I tried several times, in some cases, it seems it's almost holding up until I start tweaking the curve and then it crashes again.

Now, the file contains several layers which are part of the first steps I did. After working with it for a little, I merged the layers and used Tone Mapping Persona, leaving the previous layers still on. I'm only mentioning this because I'm not sure if those layers which are still on might affect in any way the overall stability.

 

Can I share the file in order for the dev to check it out?

In case, just bear in mind that you need to add the curve adjustment. I couldn't save the file with that layer on as Affinity Photo was crashing.

 

Best,

Piero


Piero Desopo

 

Direction, Design <http://phoenixart.com>

Photography <http://www.pierodesopo.com>

Share this post


Link to post
Share on other sites

Thanks for the file phoenixart. I've reproduced the crash so we can look into it for you. 

I did have to wiggle the curve adjustment somewhat as simply slowly dragging it seemed fine albeit a little slow. Thanks for your efforts :)

Share this post


Link to post
Share on other sites

Hi Chris,

I'm adding a new file to the same Dropbox address as I'm getting the same crash with the new beta.
I'm using 1.5.2.69 (I couldn't use 1.6.0.71 due to a problem with my Wacom).

After I add a new Curve Adjustment right above the Fill layer and I tweak the curve, Affinity Photo crashes.
I guess the bug has not been fixed yet but I wanted to bump the thread because in case the bug has been fixed then this could be a different issue.

Thanks,
Piero


Piero Desopo

 

Direction, Design <http://phoenixart.com>

Photography <http://www.pierodesopo.com>

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now