Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Recommended Posts

I don't have time to search entire forums or the interwebs to see if someone else has ever suggested this feedback before. So I offer my apologies if my suggestions have already been covered.

 

1) Please can you provide a feedback function WITHIN the application it self. It's incredibly frustrating to have to use out dated methods of signing up to god-awful web-forums which just leads to nonconstructive replies of un-thought out opinions and arguments. It also allows you to correctly link feedback (and abuse) to the software license of the user and even categorise the feedback so you can easily see which areas are causing most concern to the user base.

 

2) Please can you fix the mouse icon when painting in masks in the develop mode. The standard OS mouse icon does not feel accurate to paint with. Also a nice to improve if possible: Painting often feels sluggish to see the red tint forming. If there is a way to make this feel more responsive without upgrading an existing 32GB RAM I7 processor machine, that would be lovely please.

 

3) Cropping in Develop mode is missing an "ok" or "finished" button. It's frustrating to be sitting back with my tablet, controlling everything then having reach over to the keyboard which I moved to one side, just to hit <enter>. I don't want to map the enter key to my tablet device as it's never used for anything else! if you simply put a button in the UI it will mean I can just move the mouse there and click! perhaps I've missed a trick that does what I want, but then that would mean it's not obvious and intuitive to the user.

 

4) Please update the flash function for uploading files on this forum. Who runs flash in 2017? Browsers auto block flash from running by default because it's nasty.

 

5) More of a question then a suggestion, but is there a way to rename the overlays in the Overlays tab in Develop mode? I have 3 gradient overlays, all with the same name! that's very confusing to simple minds like myself.

 

6) Although I generally hope you spend more time fine tuning what you have already developed, instead of just rushing out new features, it would be nice if there was an in-application function for browsing image files, with a nice big preview of the image and EXIF data, which you can then double click to open it in the develop mode. I don't think anyone wants all this "importing" and cataloguing rubbish which is very slow. But browsing files within Affinity with a UI that suits photographers that windows/macOS don't offer, would be a great win.

 

Thanks for your time.

 

Went back to Lightroom because the Affinity team don't listen to feedback, instead they'd rather argue and defend themselves rather than just make their program(s) work logically. Why make things more difficult? because thats what Affinity photo does!

Link to comment
Share on other sites

  • Moderators

Hi RobLW365,

 

Welcome to the Forums :)

 

Your first 2 points would be more suited to be in the Feature Requests section I advise posting them there as the developers monitor it for future updates :)

 

3) double clicking the crop will apply it.

 

4) We will be upgrading the forum in the future.

 

5) Its not currently possible to rename overlays I'm afraid however this has been requested in the past so it may be included in a future update.

 

6) This is more likely to be a feature of our upcoming DAM application than our Affinity Photo.

 

C

Please tag me using @ in your reply so I can be sure to respond ASAP.

Link to comment
Share on other sites

Hi, RobLW365.

 

Regarding your first point, the help menu in Affinity apps includes a Support item which will launch your default browser & open the top level support page.

 

If you use that & post to the appropriate forum, I think you will find that both the staff (sometimes including the people that actually write the code) & many knowledgeable users are quite willing to help you with any issues you have. Most posts are responded to within hours, not days. Almost everyone posting here is courteous, respectful of others, & focused on providing constructive replies.

 

Aside from the general privacy & security concerns of linking feedback to personally identifiable data like a software license key, that is not possible for the Mac versions because they have no such key. Like all other apps sold through the Mac App Store, the Affinity apps are linked to a user's Apple ID, which for what should be obvious reasons Apple does not share with sellers.

All 3 1.10.6, & all 3 V2.03 Mac apps; 2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 32GB RAM; macOS 10.15.7
Affinity Photo 
1.10.6; Affinity Designer 1.10.6; & all 3 V2 apps for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 15.7

Link to comment
Share on other sites

  • 1 year later...
6 hours ago, jnoyce said:

I really don't like it how most of the words I type in English are showing up as being spelled wrong. They are spelled right but it still says they are not working.

Where are you typing them - in this forum or in one of the programs?  If it's the latter, which one?

AP, AD & APub user, running Win10

Link to comment
Share on other sites

  • 3 years later...

I just purchased Affinity "Trilogy". Affinity Designer works well on my computer, no bugs, lags and crashes. However, Affinity Photo works a bit bad. It USUALLY crashes and lags, of course i lost all of my project all over the time. Fix it pls. My laptop's specs: i5 8350U, UHD620, 8Gb DDR4 2400 and it runs on Windows 11 x64.

Link to comment
Share on other sites

4 hours ago, Duii said:

I just purchased Affinity "Trilogy". Affinity Designer works well on my computer, no bugs, lags and crashes. However, Affinity Photo works a bit bad. It USUALLY crashes and lags, of course i lost all of my project all over the time. Fix it pls. My laptop's specs: i5 8350U, UHD620, 8Gb DDR4 2400 and it runs on Windows 11 x64.

Hello and welcome to the forums.

In Affinity Photo go to Edit -> Preferences -> Performance and untick hardware acceleration.

AMD Ryzen 7 5700x | INTEL Arc A770 | 32 GB DDR4 3200MHz | Windows 11 Pro (22621.1194)
Affinity Suite V2.0.4
Better translations with: https://www.deepl.com/translator  
SVG preview in Windows Explorer with "SVG-See  Download SVG-See

"Life is one of the hardest"

Link to comment
Share on other sites

42 minutes ago, Duii said:

Why OpenCL computing acceleration makes the programs crashes?? :/ I think it should makes the program runs faster. Thank you for your help btw. 😍😍

Yes it should, but unfortunately this function runs on different hardware combinations, unstable or not at all.

And unfortunately, this feature was never part of a beta test. But I am sure that the developers are working hard on this and the other bugs.

AMD Ryzen 7 5700x | INTEL Arc A770 | 32 GB DDR4 3200MHz | Windows 11 Pro (22621.1194)
Affinity Suite V2.0.4
Better translations with: https://www.deepl.com/translator  
SVG preview in Windows Explorer with "SVG-See  Download SVG-See

"Life is one of the hardest"

Link to comment
Share on other sites

2 hours ago, Komatös said:

And unfortunately, this feature was never part of a beta test.

Are you sure? I thought the OpenCL functions were part of the initial 1.9 beta testing.

-- Walt

Desktop:  Windows 11 Home, version 21H2 (22000.613) 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 
Laptop:  Windows 10 Home, version 21H2 (19044.1706) 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
        Affinity Photo 1.10.6 (.1665) and 2.0..3  and 2.0.3.1670 beta/ Affinity Designer 1.10.6 (.1665)  and 2.0.3 and 2.0.3.1670 beta / Affinity Publisher 1.10.6 (.1665)  and 2.0.3 and 2.0.3.1670 beta
iPad Pro M1, 12.9", iPadOS 16.3, Apple Pencil 2, Magic Keyboard

      Affinity Photo 1.10.6 and 2.0.3 / Affinity Designer 1.10.6 and 2.0.3 / Affinity Publisher 2.0.3

Link to comment
Share on other sites

1 hour ago, walt.farrell said:

Are you sure? I thought the OpenCL functions were part of the initial 1.9 beta testing.

You may be right. Possibly I had slept through the 1.9.x.xxxx beta. But when I quickly browsed through the old postings for 1.9, I only saw a few that had problems with OCL

AMD Ryzen 7 5700x | INTEL Arc A770 | 32 GB DDR4 3200MHz | Windows 11 Pro (22621.1194)
Affinity Suite V2.0.4
Better translations with: https://www.deepl.com/translator  
SVG preview in Windows Explorer with "SVG-See  Download SVG-See

"Life is one of the hardest"

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.