Jump to content
Davide.Barranca

Non destructive boolean disappears when duplicating the group

Recommended Posts

Hi,

I'm facing a quite strange behaviour. I've recorded a short screencast showing it: the forum doesn't allow me to attach a mp4 file, so please see it here:

 


 

in words, it goes as follows: I've created a live (non-destructive) boolean, subtracting two rounded corner rectangles. In the video, the "Highlight" Compound Group: it has a lighter gray fill, and it's a part of a slightly more complex group with constraints – a button for an interface I'm building. 

 

As soon as I duplicate the button group, the boolean is not visible anymore. It's there, in the layers palette, but it is impossible to successfully apply a fill – it has no effect whatsoever.

 

I've several different groups with subtract non-destructive booleans, and they all behave the same. Please note that storing the group in the Assets palette and then dragging it back on the canvas has the same effect (boolean becomes transparent).

 

Thank you,

 

Davide Barranca

 

 

Share this post


Link to post
Share on other sites

Hello Davide,

I have noticed that the staff have said in several other topics that there is indeed a problem in the boolean operations. They have it on record, and they are working on addressing it.


The website is still a work in progress. The "Comics" and "Shop" sections are not yet ready. Feel free to connect with me and let me know what you like or what can be improved. You can contact me here, on my contact page, YouTube channel, or Twitter account. Thanks and have a great day!

Share this post


Link to post
Share on other sites

There are many discussions that are recovered that I miss out on too, so don't even worry about it.  ;)


The website is still a work in progress. The "Comics" and "Shop" sections are not yet ready. Feel free to connect with me and let me know what you like or what can be improved. You can contact me here, on my contact page, YouTube channel, or Twitter account. Thanks and have a great day!

Share this post


Link to post
Share on other sites

Hi Davide.Barranca,

Welcome to Affinity Forums :)

As @bleduc said we are already aware of a few issues with the boolean operations code.

If you don't mind to upload a your file with the problematic compound/object (you can delete all the rest) using this link i will add it to our log to be tested against new/improved code.

Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×