Jump to content
Sign in to follow this  
sbonsell71

Re-post because NO-ONE responded to the first post after 8 days

Recommended Posts

It's a problem exporting an image on a mac 

There are three files attached to this post:

 

an image showing a discrepancy between the image size as shown in transform box and the image size presented in the export box. (The image being exported is the button 'decouvrez votre niveau')

 

an image showing the layer set up to achieve the image

 

the affinity file itself - for someone to download it and respond

post-51228-0-52846900-1487276436_thumb.pngpost-51228-0-42527900-1487276425_thumb.pngfile not exporting correctly.afdesign

 

 

Share this post


Link to post
Share on other sites

Hi sbonsell71,

 

The size shown in the transform box is the size of the rounded rectangle and does not take into account the area taken up by the outer shadow.

 

The size in the export dialogue does include the shadow, so is larger - I would imagine that this is the expected behavior.

 

--

 

As a side issue:,When I exported your file the result is corrupted (colour is wrong, text is torn, and odd lines surrounding rectangle)

 

post-43096-0-37634900-1487278532_thumb.png

 

Did you see the same glitches in your export? Looks like a bug to me!

 

Perhaps others could try, to see if the export is also corrupted for them.

 

--

 

Finally, I've taken the liberty of rejigging your file a little...

 

The whole layer stack can be greatly simplified... if you nest the inner objects within the rounded rectangle they will automatically be cropped to size, so you do not need the additional masks / crops.

 

Also, depending on how you intend to use this graphic, you may want to ensure that you are using whole pixel values, and that your shapes are pixel aligned, otherwise you will get undesirable aliasing.

 

For example your rounded rectangle is 1131.5 pixels wide, with an X coordinate of 1313.7!

 

file not exporting correctly (Ampa Rejig).afdesign


Win7 Ultimate x64   |   i5-3570K @ 3.4GHz   |   16 GB RAM   |   120 GB SSD   |   nVidia GTX 660 Ti   |   Huion 1060 Plus

How I make GIFs >>> ScreenToGIF (Windows only, Open Source, Portable, ~600kB)

Share this post


Link to post
Share on other sites

Ampa, thanks, very helpful. I noticed the colour problem too. The issue has always been that this image is about the tenth I've done in the same format - the first worked, so I simply copied, pasted, altered text and image, then exported - with the first nine there were no problems, (though it irritated me that I had to put in three masks when just one should achieve the same goal). I'll look up 'nest' in help and see where that takes me.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×