Jump to content
Sign in to follow this  
nosillacast

Frequent crashes (hangs) saving from Photos Extension

Recommended Posts

Running Affinity Photo 1.5.1 on macOS Sierra 10.12.3.  I like to use the Apple Photos extension Edit in Affinity Photo Photo.

 

Up until now my workflow was to edit in Affinity Photo, save, close, go back to Apple Photos and save again.  

 

Lately (and constantly) if I try to save in Affinity Photo I get an error (attatched) saying failed to save document.  It is trying to save in ~/Library/Group Containers.  After I select OK not he error, Affinity Photo hangs indefinitely until I force quit and I lose all my work.

 

It's pretty consistent now so I sure hope you can solve this one. I'm especially concerned because the Affinity Photo tutorial that's poised to be released this week on ScreenCasts Online shows this exact process (back when it worked). 

 

Allison Sheridan

NosillaCast Mac Podcast at http://podfeet.com

post-44277-0-51877800-1486696595_thumb.png

Share this post


Link to post
Share on other sites

Hi Allison

 

Sorry for the delay in reply. I've been looking into this and so far I have not been able to recreate it I'm afraid. The message suggests that something else is trying to access the file at the same time. I'm guessing the only other thing that might be looking at the file at that point is Apple Photos. Before saving the file could you try closing Apple Photos and see if it now allows you to save at all?

 

Alternatively are you able to create a new user on your system and try you workflow with that?

 

Thanks

Share this post


Link to post
Share on other sites

Hello all,

 

Similar problem here A couple of days ago i installed Filters for Mac in order to use it as Photos extention.

 

The app as standalone works properly, but when used as Photots extention it freezes when i apply and save the changes. Every single time.

 

Here is what i tried to do in order to solve the issue:

 

* move filters to trash and resintall from appstore. No results

 

* move filters to trash, use recovery option of Sierra, re-install Sierra then install Filters again. Still the same.

 

* Create a new library on my "system SSD" with ONE picture and try to edit it. Still freezing when saving changes..

    Note : my library is on an external 2TB WD firewire drive, other data is on the internal 1TB drive. System on SSD drive

 

* now i'm running out of ideas. Photos Extentions configuration seems ok in the preferences menu

 

* I tried other applications from other companies like "Borders" and it works perfectly as Photos extention.

 

* Recently i decided to abandon Aperture and as replacement i would really lke to purchase Affinity Photo sofware TO USE AS PHOTOS EXTENTIONS but under these circumstances.... unless i can fix this..

 

* by the way my Imac is 27" Late 2009 4 GB ram.

 

Maybe more peopla have the same issue..?

 

(by the way, thanks for all the info and help you provide!!)

 

Thanks,

Felix 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.