Jump to content
factorzero

Freezes and general issues related to Japanese Input

Recommended Posts

I've been having a lot of issues with Designer relating to Japanese input that has making been making to close to unusable to me. 

 

English/Japanese input type switching

I have my computer set to English as the main language and Japanese as the second language. Using JIS keyboard. Inside of Designer when using the language switching key the language will often get stuck and English or Japanese and I'm unable to switch language inputs until changing to another application. Pressing the input mode switch key 「英数」on the JIS keyboard sometimes registers as a space character as well. The behaviour is really inconsistent. This is very inconvenient for text input especially because it leads to the second bug...

 

Freeze/Crashing when exiting a text field in Japanese input mode

After inputing japanese text with the keyboard input mode still in japanese mode, and the text field editing active, pressing the escape key and then attempting to change tools(v shortcut) the app freeze indefinitely. Switching to english input mode before hitting the escape key seems to prevent this from happening, but because input switching is broken the keyboard is often stuck in japanese mode causing this to happen pretty often.

 

I've been trying to add this app into my main workflow but unless there is a clear fix I feel like I'm going to have to drop it.

Share this post


Link to post
Share on other sites

Hey factorzero, welcome to the Affinity Forums.

I've been trying to work through your issues but I'm not having much luck. If you have a few minutes, could you possibly record your screen and attach the clip so I can follow you exactly? I'm pretty sure I got a freeze once when hitting esc and then using the tool shortcuts but I can't get it to happen again. I know I'm close  -_-

Share this post


Link to post
Share on other sites

Hi Chris,

 

I made a new document, and recorded a screencast of the issue. I couldn't get it to freeze using the escape key this time but you can clearly see some weird stuff going on. When I typed "ああああああああ" and then created a new text object the content of the new object automatically filled as "あああああああああ". At about 1:20 you can see the IME window actually get stuck, and persisting even after exiting the text field.

 

https://youtu.be/LMUegCHAETU

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×