Jump to content
lightmill

Affinity Designer: Failed to open / save document

Recommended Posts

Since the a recent update to Affinity Designer or Mac OS Sierra (I can't pinpoint exactly which) I'm no longer able to open or save any files.

 

When I try to open an existing file I get the message "The file could not be opened because permission was denied".

 

If I create a new document and try to save it I get the message "Save failed because you do not have permission to create a file in that location".

 

I've tried a variety of locations (Desktop, Documents, Dropbox, root level of HD) all with the same result... I've tried setting file permissions to "Read & Write" for all levels. Obviously Mac OS Sierra no longer has any option for repairing disk permissions, so I'm a bit stumped!

 

Any ideas?

post-5356-0-63733200-1485111304_thumb.png

post-5356-0-75371000-1485111320_thumb.png

Share this post


Link to post
Share on other sites

I'm having a similar problem with Affinity Designer on a new MacBook Pro running Sierra macOS 10.12.2. I can't open SVGs or recent PDFs from other apps. I'm getting "The file was not found."

 

I get this Designer dialog whether the file is in iCloud Drive or in the Mac's SSD Documents folder.

post-49840-0-97084000-1485132247_thumb.jpeg

Share this post


Link to post
Share on other sites

I just now updated macOS to 10.12.3. Affinity Designer still won't open SVGs or PDFs made by other apps. The Mac's Preview app, TouchDraw, and Graphic apps produce files that Affinity Designer can't find.

Share this post


Link to post
Share on other sites

Same problem here.
After working a while in AD I got that message. Closed Affinity Designer and restarted it – now the file could be opened again …

 

 

 

post-25927-0-72952500-1485267868_thumb.png

Share this post


Link to post
Share on other sites

I haven't been using Affinity Designer for a while because I was having good luck with Graphic. I decided to try again today to see if maybe the fault cured itself on my 2016 15" MacBook Pro with touch bar.

 

I was able to open an SVG made by MagicDraw, read by Graphic, and saved by Graphic. AD did open the SVG from MagicDraw directly, but an old issue remains where AD does not render rasterized text (rotated 90°) at all. Graphic does handle those rasterized images - it's the reason I switched to Graphic some time ago.

 

I now also have the problem that AD will not Save nor Export anything to the Finder. Earlier I couldn't Open files, now I can't Save them. Since this is a new machine, maybe it's an Apple problem. Still I do not have these problems with other applications.

 

Affinity Designer has an Ungroup All feature that would save me a lot of time as the diagrams I work on are very large. I would sure like to be able to use AD on the new machine, particularly for that. I've become quite familiar with AD as it worked very well on my older MacBook Pro in the past.

post-49840-0-89495600-1485591625_thumb.png

Share this post


Link to post
Share on other sites

I'm having similar issues with not being able to save AI files I'm trying to convert. I can open and convert one or two, and then the next one causes the failure error. I have to quit and restart AD and then it works again for one or two more files.

post-3099-0-48954600-1486044329_thumb.png

Share this post


Link to post
Share on other sites

Hey,

 

It sounds like a typical case of a backup/cloud service is constantly reading/backing up the files preventing you from modifying them. We've seen it a few times on Windows. Can you confirm if you have anything like this running? Try disconnecting from the net and trying. 

Share this post


Link to post
Share on other sites

@JeffHayden - Have you tried simplifying the name of that file? Not only is it long but it has dots and hyphens in it. It shouldn't be a problem but it might be worth trying. 

@Mr. K - If you have no software backing up your files, it is no doubt a permissions issue. Have you tried completely clearing the app from your Mac and done a fresh install? 

What are your permissions for the .afdesign extension? If you find an existing file > right-click > Get Info and look at Sharing & Permissions at the bottom, what is it set to? 

Share this post


Link to post
Share on other sites

I finished converting my files. It required a restart of AD every time I got the error. I also found that if I didn't close the files after conversion I could convert a lot more of them before I encountered the error. It seems like a AD bug to me.

Share this post


Link to post
Share on other sites

I have exactly the same issue. It happened from one day to the next. Files I could open yesterday now give me the same permission message as above.

 

It won't even let me save files either.

 

I'm on a mac with sierra.

 

 

I'm in the process of transitioning from AI to affinity for live projects, so needs this not to happen. 

 

 

Thanks.

 

PS. this looks like the same issue to this thread: https://forum.affinity.serif.com/index.php?/topic/36945-failed-to-open-afdesign-file-due-to-missing-permission/?hl=permission

Share this post


Link to post
Share on other sites

For me, this seems to be a font issue. When I activate more than a certain amount of fonts, I can't open image files and I can't save Affinity Photo files I create. But when I reduce the amount of fonts to under 8,000 (I think that was the amount I had before this issue started), I can open image files and save without issue. 

 

I am still testing to see exactly how many fonts will not produce this issue. So far, I've tested this 3 times by turning a certain amount of fonts on and off and I am able to replicate the issue each time, then alleviate the issue by reducing the amount of fonts activated. I will report back on the number of fonts that can be kept active without issue.

 

UPDATE (5.5.2017) - The number for me seems to be 9,300 fonts activated and I can save and open files without incident. After that, the permissions issue presents itself. For reference: I am on MacBook Pro 15-inch, 2016, Processor is 2.9 GHz Intel Core i7, Memory is 16 GB 2133 MHz LPDDR3, Graphics are Radeon Pro 460 4096 MB, Intel HD Graphics 530 1536 MB.

 

UPDATE (5.9.2017) - It began acting a little buggy at 9,300, but intermittently. I am now at 7,644 fonts and have no issues with saving or opening.

Edited by iambia

Share this post


Link to post
Share on other sites

I searched to see if anybody else was having this issue and looks like I'm not alone. :) I've started noticing this more frequently. I often quit and reboot the app and that often seems to do the trick but not always. I too was thinking maybe it was only files from Google Drive but yeah it's happening on desktop as well. Would love to hear if there's any update!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×