Jump to content
You must now use your email address to sign in [click for more info] ×

Recommended Posts


Since I became a User of Affinity products, in particular PHOTO, I have been asking BOTH Serif Affinity and Filter Forge( FF)  to have FF  compatible with Affiny Photo. Others have also  asked too.


Filter Forge are HAPPY to Oblige, but sttae that they are not hetting responses form Affinity.. e.g.



QUOTE from FF in response to a FF user on the Official FF Face Book Page:-



Hi Bill, honestly, we'll be able to make this fix if Serif will give us their licenses. We've contacted them long ago and still don't have Affinity licenses. If you can contact them with this, we'll be very grateful to you.



I have also posted on the FF Facebook page, in there Affinity Forums and also in the Affinity Designer and Photo FB page...


so, PLEASE could someone from Affinity contact Filter Fporge and get this ball rolling! I believe that some FF users may be interested in AP and and vice versa.


What is the problem please?   I am happy to do what i can to help all you guys out on this. one................... Thank You.


Angela H Evans







Link to comment
Share on other sites

Hi LyricsGir

Not sure what version of Filterforge you have but I do know both version 5 and 6 works fine in AP because I did have version 5 installed and have recently upgraded to version 6 which works fine. I work on mac but If it works on the mac version of AP as it does then there is no reason why it should not work on a windows version. Have you tried installing latest version (if you can justify the additional expense).

Link to comment
Share on other sites

Hi LyricsGirl

Just read a post by one of the staff at Affinity which I hadn't yet read, it appears there is a difference in the way FF reacts with the Mac OS and windows. On this basis, as it doesn't work for you I assume you're on windows so are dependent on FF to make it work on windows platform within AP. I'm sure as AP becomes more popular as a professional choice FF will have to get its act together and make their software work for both platforms.

Link to comment
Share on other sites

  • 1 month later...

Hi just thought you might like to know if you don't already, Filter-forge has just issued an update today (1March) which fixes some bugs but also now includes support for Filter forge. Good news all round yet another developer on board.

Link to comment
Share on other sites

Yes I did but your post says version 6 not 6.007 which was issued today specifically aimed at support for Affinity Photo generally not just for windows. I posted this not just for you but as a general post for anyone reading this issue that may also be having problems on mac. Sorry you appear to have got the hump! Not a big deal really is it, life goes on.

Link to comment
Share on other sites

Hey Angela,

I've already started chasing this up for you. We appreciate the effort you are putting in on behalf of everyone else. I'll hopefully be able to provide you with an update soon  :)


WOW! I'm totally disappointed!








Was Chatting with the people at Filter Forge asking why Mac isn't working with the plugin. I was told the problem is on this side with Mac programmers.





Very loyal Affinity user.


My FaceBook Page of 3500 users and half are disappointed:



Link to comment
Share on other sites

  • 2 weeks later...
  • 2 months later...

Ok. So I'm running Filter Forge 6 Mac 6.009. I was able to load up the filter in the filters area but it's greyed out. Is 6 not supported? I checked the box to use unknown filters.


I've been reading this months-long thread. Really, this A) Shouldn't be that hard for the Serif engineering team to address and B) Affinity team people should be talking to us about this more, and with greater clarity.


The FilterForge people remain open to helping Serif. Unfortunately I'm still seeing on there end that there is not reciprocal love from Serif


Please fix that and get these into the plugins. Using the external app is slow and time consuming.



Link to comment
Share on other sites

  • 3 weeks later...
  • 1 month later...

I have Affinity Windows ( and Filter Forge 6 (6.009) and I can neither get Filter Forge to work (see attached error message), nor can I delete Filter Forge in order to update the connection in Affinity without a crash (see attached).


Any help in regards to getting this to work would be greatly appreciated...thanks! 

Filter Forge Error Message.JPG

FF Unhandled Exception Crash.JPG

Link to comment
Share on other sites

Will someone please tell me how to get Filter Forge plug-ins to work in the MAC version of Affinity Photo. I have AP version 1.5.2 and FF version 6.009 Profesional version.  I have manually created an alias for the FF universal plugin and placed it in the AP folder.  I also created an alias for Nik Collection in the same AP plug-in folder.  Nik Collection works fine, but Filter Forge is not recognized as a plug-in.  I have read all the posts and tried multiple things.  I understand this works on the Windows version of AP, but I want an answer for the MAC version from the developers at Affinity.  Just tell me it is coming in the next version, or how to install a work around in this version.  It is quite annoying to have to read all the post on AP and FF in order to understand that this issue is receiving the official finger pointing from both development teams.  



Link to comment
Share on other sites



Through trial and error, I got the MAC version of Affinity Photo (1.5.2) to work with the Filter Forge (6.009 and trial version 7.0).  I have tested both FF versions on 8 bit color photos, and each one performs as expected.  The problem was aliasing the universal plug-in and placing it in the default AP folder.  This will not work.  Once I created the path to the applications/Filter Forge 6.0 directory in the preferences of AP, then all works fine.  I wish someone would have explained to me the exact procedures.



Link to comment
Share on other sites

4 minutes ago, Cronicm said:

I wish someone would have explained to me the exact procedures.

For future reference, many apps do not work correctly if items they expect to be in a specific location are replaced with aliases to some other location. A few do not even when the replacements are symbolic links.


There are several possible reasons for this, including all or some part of a file path being hard coded & permissions issues due to sandboxing or for other security considerations.


The bottom line is never assume an alias or symlink will work without testing.

All 3 1.10.8, & all 3 V23.0 Mac apps; 2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 32GB RAM; macOS 10.15.7
Affinity Photo 
1.10.8; Affinity Designer 1.108; & all 3 V2 apps for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 15.7

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.