Halo

Tablet / Denoise Filter and Brush Size Hotkey Problems

10 posts in this topic

I have found some problems that are, for me, gamebreaker.

 

I am a long time Photoshop user and like Affinity photo much, but some of the current bugs are problematic.

 

1.) Tablets and wobbling lines

I use a Wacom Intuos 5 with up-to-date drivers. The "wobbling / straight lines" problem make drawing difficult.

I think i have found the root of the problem:

If you use the "Histoy-Tab", the "wobbling" lines will be drawn. If you switch to any other tab (transform, navigator or channels), the issue is greatly reduced. Can you please check this?

 

2.) Denoise Filter

If iam use the denoise filter, the "details" slider does nothing!

 

3.) Brush Size  / Hardness "Hotkey"

Can you change the shortcut for this? It's really cumbersome to press one key AND 2 mouse buttons.

The way it is done in Photoshop is more elegant. It's also impractical with a tablet.

 

I want to make the transition to a Affinity pipeline, but with these "bugs" iam stuck with PS.

 

I hope i have given some helpful input - keep up the good work!

 

*sorry about grammar or other errors, english is not my first language and a little bit "rusty"* :)

Share this post


Link to post
Share on other sites

Hey Halo, welcome to the Affinity Forums :)

1) I have struggled to reproduce this in the past. What you have suggested as the cause may be true, I'm trying to work through it now.

 

2) I'll pass this on :) Thanks

 

3) We are looking at changing this as we realize it is a bit awkward. It has been mentioned quite a few times but at the moment we can't change it.

Thanks for this. I'll get back to you about the first issue once I've spent more time on it!

Share this post


Link to post
Share on other sites

I have tested the last build and the same problems persist.

These bugs have been known since last year.

 

Is there a timeline for the fixes?

Share this post


Link to post
Share on other sites

Hey Halo,

 

1) We will be making improvements to drawing/painting which I hope addresses this.

2) The bug was assigned to a developer but there has been no movement so I'll bump this.

 

3) Although this is can be slightly annoying, improvement issues are considered a lower priority than bugs. We have to be careful that we don't change something to suit one group of users but ultimately annoy another group by changing it. 

We don't generally provide timelines for fixes. I can tell you if a bug has been updated to be fixed for a certain version prior to its release but I couldn't tell you how dev prioritise what they will be working on.

Share this post


Link to post
Share on other sites

So, after another half year, i tested the last beta build and... again, the same reported bugs. :(

I want really work with this good app, but expecially point 1) and 2) are gamebreaker for me.

After that long time, iam dissapointed - i posted these bugs in the forum and yet, no fixes...

Share this post


Link to post
Share on other sites

Hey Halo,

 

I've just checked this in the current beta and the Denoise Detail slider is definitely doing something but it is extremely subtle (maybe too subtle). It seems to be more obvious the more the Luminance Denoise slider is increased.

Have you been using the beta? There has been a lot of work done with brushes so I'd definitely recommend having a look at that. We plan on releasing 1.6 in November if you would rather wait for the release version to be patched. 

Share this post


Link to post
Share on other sites

Hello Chris,

i have tested the latest beta.

The problems i mentioned still persists. When i change the settings on the detail slider, there is a slight "rerendering" of the image, but in end, there is no change.

The main problem with the brushes is that when you paint fast curved lines, like hair, the lines are not "round" in the start. They are straight.

Its really easy to test with a tablet. Please check the comment from me in the beta forums months ago.

If you use the "History-Tab", the curve ist not a curve in the start (if you draw fast). If you switch to any other tab (transform, navigator or channels), the issue is greatly reduced.

This might be a problem with the threading of the app in this case.

 

Share this post


Link to post
Share on other sites

Hey Halo,

 

I'm not trying to be difficult but your original message said that the Details slider does nothing, but it does do something, it's just very subtle and I'm not sure if this is intended, but I've asked development if this needs tweaking so we'll see what they say about that.


I think the History Panel being displayed does make this a little bit worse which we knew about from the start. It had an affect on other areas too but these have been improved. I looked at the original bug report from a year or two ago (made by another user) and it has improved but we're not quite there yet. 

I also put another bug report in recently where doing very quick circles caused numerous straight lines and Dev have acknowledged this and are working on it.

Have you tried using the Stabiliser settings on the context toolbar?

Share this post


Link to post
Share on other sites

Hello Chris,

thanks for the response. I appreciate that the devs will look into these problems.

Yes, i have used the Stabilizer, but its not the best solution for my problem or my drawing style.

I hope that these things will be better in the near future, because Affinity Photo and Affinity Designer are great Apps and have the potential to eliminate the need for Photoshop / Illustrator.

Chris B likes this

Share this post


Link to post
Share on other sites

Hello Chris,

i have one more question on the topic with the "History-Tab active -> straight-not-round lines" problem, when you draw fast.

You mentioned that the devs know about it. Is there any ETA for a fix?

Because my time is limited and it is a little bit frustrating to test every new beta and that "bug" remains.

Also these things are not a little bit worse, they are huge differences when the history tab is active or not.

 

For reference i attached some screenshots.

The first three are about the drawing problems. The other two illustrate my problem with the details slider (the picture is not from me, but a free one).

I don't know if i have some weird problem that no other one has, but its a main task to denoise some pictures i make with my camera.

Whats really strange is, these two pictures are made with the snipping tool -> carbon copy from display framebuffer.

In Photoshop these are absolute pixel identical -> details slider does nothing.

 

One point i haven't mentioned before is an error in the rendering of images. The edge smoothing on percentages other than eg.: 50%, 100%, 200%. is bad.

I have attached these pictues too. I hope that will help. If you have any questions one these topics, don't hessistate to contact me - we all want a good product! :)

 

Maybe you can forward these attachements to the devs.

Thanks in advance!

 

 

Denoise-Test- 0 details.PNG

Denoise-Test- 100 details.PNG

Drawing Aliasing in Affinity Photo.PNG

Drawing Aliasing in Photoshop.PNG

History Tab active with stabilizer.PNG

History Tab active.PNG

History Tab not active.PNG

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now