• Announcements

    • Patrick Connor

      Forum Upgrade   07/12/2017

      Welcome to the upgraded Affinity Forums. This change will allow us to add more features and block spam better. If you have any problems using these forums as a result of the upgrade, please post in the the similarly named News forum thread.
kukur

Affinity Photo 1.5.1 Crashes

12 posts in this topic

Hello All,

 

I recently purchased the 1.5.1 version of Affinity photo and installed it on my current iMac. This machine is running 10.8.5, 2.5GHz i5 with 4GB mem. These appear to be within the specs of the software but I am having issues with the software.

 

When I try to open a .CR2 file from my Canon 6D, the software crashes. I can open a single .jpg (after conversion in another software) but when I try to do HDR or something with multiple images, the software crashes.

 

Looking for some help to curb the crashing. Looking forward to moving on from Photoshop and supporting a great product in Affinity.

 

L

post-48632-0-02693100-1484043718_thumb.png

Share this post


Link to post
Share on other sites

Hey kukur, welcome to the Affinity Forums :)

I've tried with a few sample files from a Canon 6D and they seem to be okay. Can you send me an offending image so I can look into this further? Thanks!

Share this post


Link to post
Share on other sites

Here is one I just tried opening and it crashed upon load. I thought it may be the OS/Raw compatibility (10.8 and Canon 6D), but that would not explain why multiple tiff/jpgs won't open. I have been putting off upgrading until I could find a replacement to my Aperture workflow (hint, hint), but I may just have to make the move and cope.

 

I may try uninstalling the software as well. Seems odd it would have issues on a fresh install (no upgrades).

 

The RAW file is too big to upload (23mb). So I have uploaded it to my server.

 

http://kukur.com/AffinityTest.CR2

 

L

Share this post


Link to post
Share on other sites

It may not solve the problem but adding ram wouldn't hurt, especially when working with large files. I can open the file on my i3 processor iMac running Yosemite OS (10.10), no problems. I also have 14 gigs of ram.

Share this post


Link to post
Share on other sites

I have no problem with it either  :unsure: Then again this late 2013 iMac has 8GB of RAM so that might be making the difference as Franklin has said. I'll see if I can get hold of a slightly lower spec machine to test it on. I would have suggested trying it on the recent beta but it has expired today by the looks of things. 

Share this post


Link to post
Share on other sites

Well, I upgraded to 10.12 and can open the files in Affinity Photo now. So it may be a combination of all things stated. Bummer part is now that I upgraded I lost access to Aperture. So I will begin to assess that problem.

 

Thanks for the help gentlemen. Looking forward to seeing what I can do now.

 

L

Share this post


Link to post
Share on other sites

Hey kukur, thanks for letting me know. I'm sorry about Aperture. I am actually quite surprised upgrading your OS X had an impact on this... 

Share this post


Link to post
Share on other sites

Well, I upgraded to 10.12 and can open the files in Affinity Photo now. So it may be a combination of all things stated. Bummer part is now that I upgraded I lost access to Aperture. So I will begin to assess that problem.

 

Thanks for the help gentlemen. Looking forward to seeing what I can do now.

 

L

I'll lose access to Lightroom feature when I update to sierra so I decided to start using the free version of Capture 1. It said it's for Sony owners but I didn't have to provide any proof of my Sony camera.

I'm enjoying it so far. It's actually a lot faster as well

Chris B likes this

Share this post


Link to post
Share on other sites

Hi guys. I have the same problem as the original poster.

 

I have Affinity Photo 1.5.1 on a late 2012 Mac mini with 4GB RAM and OSX Mountain Lion 10.8.5.

 

If I try to open a NEF file from my Nikon D7000 directly in AP, it crashes every time.

 

If however I open AP as an external editor via Lightroom 4, the TIF that is created opens and edits fine.

 

I need to keep running 10.8.5 for a few reasons so would appreciate a fix for this.

 

If you require further details, or a copy of the crash log file please let me know.

 

Thanks,

 

Richie

Share this post


Link to post
Share on other sites

Hi Richie, welcome to the Affinity Forums.

The reason the file opens when selecting Affinity as the external editor is because it is converting the image to a TIF as you have said. I've tried a few D7000 samples from a website and they seem OK.

 

Can you upload an example here so I can take a look? You can try changing the RAW engine to Apple. Go to the Assistant at the top (looks like a tuxedo) and click Develop Assistant at the bottom and then change RAW Engine to Apple. 

Share this post


Link to post
Share on other sites

Hi Chris. Thanks for reply. Considering the original post from kukur, this feels like an issue specific to OSX 10.8.5. I'll find some sample raw files from other cameras and test with those to see what happens. I'll report back when I have results.

 

Most of the time I use AP as an external editor from Lightroom, but it would be nice to have the option to open the raw directly in AP.

 

Update: Forum topic 30973 suggests this issue may have been fixed in 1.5.2 beta 2. I'll try the latest beta and then report back.

 

Richie

Share this post


Link to post
Share on other sites

 

 

Update: Forum topic 30973 suggests this issue may have been fixed in 1.5.2 beta 2. I'll try the latest beta and then report back.

 

 

That would be great, thanks :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now