Jump to content
NobleValerian

Ctrl+Shift+C Selection > New from Clipboard > Wrong Size

Recommended Posts

If I make a marquee selection, :: Pause :: It still has that problem where I have to change tools and come back to the marquee tool to manually transform the dimensions :: UnPause :: then copy flattened, then create a new file from clipboard, it is inexplicably larger than the selection by exactly 2 pixels.

So if I make my selection sized 1280 px by 720 px, in a document sized 1920 px by 1080 px, then create a new document from that selection, the new document is 1282 px by 722 px.  If the selection is the same size as the document, it doesn't do this.

If my document and selection are the same height, but the document is wider than the selection, and I snap the selection to the left or right, then there is an extra pixel in the new file.  If I center the selection with the document extended to the right and left (and the selection and document height still match), then there are two extra pixels in width, but not height.

If I create a box out of the pen tool, size that to 1280 px by 720 px, then tap the button in the pen tool to make it a selection, then copy that flattened and create a new file from clipboard... it's exactly what it's suppose to be.  Since I don't know how to make a shape into a selection, like the handy button in the path tool, I'll make my way to the feature requests, too.

Share this post


Link to post
Share on other sites

So, the last time I tried to control click on a shape layer to get a selection out of it, it didn't work.  Photo also crashed that session, so maybe something else was going on.  The relevant thing is, if I use the shape tool to create a rectangle, transform the rectangle to 1280 px by 720 px, control click the shape layer to get a selection, then copy flattened and create a new file from clipboard, that is also exactly 1280 px by 720 px.  The selection tool still gives me two extra pixels.  It's also important to note that it doesn't matter that feather is set to 0 px, or whether Antialias is checked.  This is what is created using the selection tool.  It's not like there are just extra pixels, the edge isn't clean at all, so there are new white pixels that shouldn't exist at all and the solid color I copied is no longer opaque around the edge.

 

untitled_by_noblevalerian-datazqd.png

 

I played with it a more, and it seems like when I click "Refine..." the "Matte Edges" box is checked.  If I uncheck it, or just reduce the Border width, and click apply, it exits out.  I copy that into a new file, and nothing has changed.  When I click refine again, it shows it exactly as before making the changes.  It's just not changing my selection.

Share this post


Link to post
Share on other sites

Hi Noble,

It initially sounds as though you're selections are not matching up to the pixel grid (this is noticeable if you set Pixels to have 1 or more decimal places in Preferences > User Interface which it is by default). However I presume you are using Photo (based on your second post), which should snap the Marquee Selection tool to the pixel grid.

I've tried myself on a couple of photos and the new document is always being created the same size as my selection region. Are you able to record some videos demonstrating the issues you are encountering at all please? It maybe the way your document is possibly set up - could you try opening up a simple JPG creating a rectangular marquee selection and copy and paste that to a new document please and see what you get?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.