Jump to content

Recommended Posts

When I use a brush I know which one I'm using because it's highlighted.

 

If I then use a selection tool - L and come back to the brush tool - B, the brush is no longer highlighted, now it's no longer identifiable. What brush am I using? How can I know?

 

Is there a way to know what brush is currently being used?

Share this post


Link to post
Share on other sites

Hi Sarvasri,

 

Welcome to the Forums :)

 

There will be a dark square around the tool you currently have selected. (see attached)

 

C

 

 

post-12469-0-73544800-1483966497_thumb.png

Share this post


Link to post
Share on other sites

There will be a dark square around the tool you currently have selected. (see attached)

 

That only tells you which tool you are using (e.g. the Paint Brush Tool). It doesn't tell you anything about the brush stroke. ;)


Alfred online2long.gif
Affinity Designer 1.6.5.123 • Affinity Photo 1.6.5.123 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.6.12.86 • Affinity Designer for iPad 1.6.4.45 • iOS 12.2 (iPad Air 2)

Share this post


Link to post
Share on other sites

That only tells you which tool you are using (e.g. the Paint Brush Tool). It doesn't tell you anything about the brush stroke. ;)

 

I missed the first line when I read this earlier I'm not sure how! 

 

 

This is a known bug with the Windows version which we have logged for our developers to fix in an upcoming version :)

Share this post


Link to post
Share on other sites

That only tells you which tool you are using (e.g. the Paint Brush Tool). It doesn't tell you anything about the brush stroke. ;)

So is there any way to identify which brush is being used after going somewhere else? Could this be something easy for the developers to include?

Share this post


Link to post
Share on other sites

So is there any way to identify which brush is being used after going somewhere else? Could this be something easy for the developers to include?

 

It should already identify which brush is being used. The fact that it doesn't (on Windows) is a bug.

 

This is a known bug with the Windows version which we have logged for our developers to fix in an upcoming version :)


Alfred online2long.gif
Affinity Designer 1.6.5.123 • Affinity Photo 1.6.5.123 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.6.12.86 • Affinity Designer for iPad 1.6.4.45 • iOS 12.2 (iPad Air 2)

Share this post


Link to post
Share on other sites

It should already identify which brush is being used. The fact that it doesn't (on Windows) is a bug.

When I select a brush and use it, the brush is highlighted in the brushes panel. I know for sure which brush I'm using.

Then let's say I use the lasso tool to make a selection. When come back to the brush tool, the same brush is available, but it is no longer highlighted in the brushes panel. I can see the "footprint" of the brush, but now I can't associate that brush with the panel. There is no selection. So I don't know which brush I selected last time because there is no indicator of which brush is being used right now. I am left guessing. This is on a Mac. Is the brush choice indicated somewhere else and I just don't see it? Try it and you'll see what I'm talking about.

Share this post


Link to post
Share on other sites

When I select a brush and use it, the brush is highlighted in the brushes panel. I know for sure which brush I'm using.

Then let's say I use the lasso tool to make a selection. When come back to the brush tool, the same brush is available, but it is no longer highlighted in the brushes panel. I can see the "footprint" of the brush, but now I can't associate that brush with the panel. There is no selection. So I don't know which brush I selected last time because there is no indicator of which brush is being used right now. I am left guessing. This is on a Mac. Is the brush choice indicated somewhere else and I just don't see it? Try it and you'll see what I'm talking about.

 

Well, I've tried it in both AD and APh on Win 10, and the brush doesn't lose its highlight in either app when I switch from the Paint Brush Tool to the Free Hand Selection Tool ("lasso tool") and back again. Maybe Callum was referring to something slightly different when he said it had already been logged to be fixed.


Alfred online2long.gif
Affinity Designer 1.6.5.123 • Affinity Photo 1.6.5.123 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.6.12.86 • Affinity Designer for iPad 1.6.4.45 • iOS 12.2 (iPad Air 2)

Share this post


Link to post
Share on other sites

I have the same problem MacBook Pro Retina, Mid 2012 15 in.  OS X 10.11.6, El Capitan this is a real PITA. needs to be fixed.


Mac MacBook Pro 15 in.  OS X 10.9.5, Mid 2012 456.77 GB Affinity Design and Photo.

Share this post


Link to post
Share on other sites

I have the same problem MacBook Pro Retina, Mid 2012 15 in.  OS X 10.11.6, El Capitan this is a real PITA. needs to be fixed.

Yes, mine is a 2011 MacBook Pro, El Capitan 10.11.6. This is definitely confusing. I always lose the brush highlighting.

 

I would like to see the brush identified somewhere. Highlighting is good, but a better method would be to show the category and brush name, plus a highlight. For instance, a box could show a breadcrumb trail similar to how it is done on some web sites and file systems. Then if I go to another category I would still know which category and brush is active. I could get back to it. Otherwise, I'm lost.

 

Do the developers monitor these posts? Should this go in as a suggestion somewhere?

Share this post


Link to post
Share on other sites

Do the developers monitor these posts? Should this go in as a suggestion somewhere?

 

I suggest that you post to the Feature Requests subforum.


Alfred online2long.gif
Affinity Designer 1.6.5.123 • Affinity Photo 1.6.5.123 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.6.12.86 • Affinity Designer for iPad 1.6.4.45 • iOS 12.2 (iPad Air 2)

Share this post


Link to post
Share on other sites

Yes, mine is a 2011 MacBook Pro, El Capitan 10.11.6. This is definitely confusing. I always lose the brush highlighting.

 

The same here! MacBook Pro (a little younger than yours) and El Captain. And confusion also!

 

My brush lose his highlight also after a short jump to the second open document and back.

And – Murphy's law – I have still open two or more files :rolleyes:

 

Working with a few similar brushes and many tools I have frequently (and not only after a break) a second brush-question:

 

Which one is now (temporary) changed?

... simple because a brush lose his highlight also even where a little bit of settings has changed, e.g. the size(!). AP means, changing the size or opacity I crate permanently new (not saved) brushes. It is of course logical, but not the best usability-reason.

 

 

I would like to see the brush identified somewhere. Highlighting is good, but a better method would be to show the category and brush name, plus a highlight.

 

••• The name of category is not a problem: you see the name on the top of your brushes panel and you stay, whatever you do, in the same category (except you change it manually in the pull-down of the panel).

••• The name of brush as such is also not a problem. Mouse-over in the brushes panel and you see all the names.

 

The consistent and correct application of the highlighting is what we need. We can see the name of highlighted brush after mouse-over or in the title of setting-window after a click in the brushes panel.

After a change – of a tool, a file or of a brush settings – we see nothing :angry:

 

My usability-suggestion would be:

- to highlight a current brush in the panel after the change of tool or document or who knows what else (it is a bug!)

- to highlight a brush as a "current and temporary changed" in the brush-panel. Of course in different way than "current and original". (As a nice-to-have)


••• MacBook Pro | El Captain 10.11.6 |
••• Affinity Photo 1.6.6 | Affinity Designer 1.6.0
••• English 0.0.2 (Beta) | … I'm sorry!

Share this post


Link to post
Share on other sites

Well, I've tried it in both AD and APh on Win 10, and the brush doesn't lose its highlight in either app when I switch from the Paint Brush Tool to the Free Hand Selection Tool ("lasso tool") and back again. Maybe Callum was referring to something slightly different when he said it had already been logged to be fixed.

The highlight loss definitely occurs on the Mac version here. In fact, it does not matter which other tool I switch to; the highlight goes away whenever I switch tools & does not come back when reselecting the Paint Brush tool. The only clue about that I get is the width setting in the Context toolbar, but that is not much help.


Affinity Photo 1.6.7 & Affinity Designer 1.6.1; macOS High Sierra 10.13.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 1.6.11.85 & Affinity Designer 1.6..4.45 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iOS 12.1.1

Share this post


Link to post
Share on other sites

••• The name of category is not a problem: you see the name on the top of your brushes panel and you stay, whatever you do, in the same category (except you change it manually in the pull-down of the panel).

••• The name of brush as such is also not a problem. Mouse-over in the brushes panel and you see all the names.

 

 

 

This is a problem for finding the brush you are using. If you go somewhere else in the brushes panel, unless you remember both the category and the brush, you have trouble finding it again. Yes, you can see the brush names, but you have to mouse over all of them one at a time to locate a name. And you would have to do that for every category. Not a good solution. Breadcrumbs is the best solution.

Share this post


Link to post
Share on other sites

Hi everyone,

 

I have faced this issue especially when painting in Affinity Designer. If i am using multiple brushes in a single painting i cannot select them by sampling them from the paint on the canvas. Lets say if i have utilized 7 brushes in my painting,then there must be a way for me to select any of them by sampling them. This mechanism is actually available in the mypaint software that i have used a lot. In order to select a brush from a painting in my paint,you move the cursor over the brush stroke and press the 'w' key to sample and then select the brush[along with its settings] without selecting and remembering the brush from the brush panel. Here is a short video demonstrating this feature as i do many brush strokes and select those by sampling them. A similar feature should also be available in affinity designer and photo,as if we are using close to a lets say 25 brushes in a painting,do we need to remember each of them?. This feature will boost our productivity.

 

Brush_Tool_in_MyPaint_Brush_Selection_Based_on_moving_the_Cursor_and_pressing_w_key_to_select_Brush_from_painting.gif

Share this post


Link to post
Share on other sites
On 12/26/2016 at 12:37 AM, Sarvasri said:

Is there a way to know what brush is currently being used?

The question was from 2016! The problem (or bug?) is still there... :31_neutral_face: (AD Windows desktop)

Is there at least one way to save the current brush as a new one?

 

Share this post


Link to post
Share on other sites
On 1/9/2017 at 2:45 PM, Callum said:

This is a known bug with the Windows version which we have logged for our developers to fix in an upcoming version :)

Its in mac too. Even in 17103. As soon i switch a tool, the blue highligt in brush panel disapperars and will not re-appear when go back to the brush-tool. 


OSX 10.13.5  / iMac Retina 27" / AMD Radeon R9 M380 / Metall: on!

Share this post


Link to post
Share on other sites
On 11/30/2018 at 5:41 PM, Polygonius said:

As soon i switch a tool, the blue highligt in brush panel disapperars and will not re-appear when go back to the brush-tool.  

Same thing if I simply change the size of the brush. The best thing would be like in Photoshop: right-click to change the size of the brush, and it is still highlighted in the brushes panel. :)

Share this post


Link to post
Share on other sites
On 11/30/2018 at 10:09 AM, dinosaura said:

The question was from 2016! The problem (or bug?) is still there..

Other questions and suggestions too... it seems some things must remerberd from time to time

 


OSX 10.13.5  / iMac Retina 27" / AMD Radeon R9 M380 / Metall: on!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×