Jump to content
Davide.Barranca

Blending modes don't work on Outline fx (Gradient)

Recommended Posts

Hi, Affinity Designer 1.5.4, macOS 10.12.2.

I've a shape like this:

 

image.png

 

I'm trying to apply an Outline fx, using a Linear Gradient, black to white, set in Screen blending mode.

I would expect the values from black to mid-gray not to influence the shape color, and the ones from mid gray to white to make it lighter, such as this (mockup created using a toroid shape):

 

image.png

 

Instead, the result of the fx is like Normal blending mode: in fact it seems all gradient outline blending modes work as normal.

 

image.png

 

 

Do I have wrong expectations?

Thank you,

 

Davide Barranca

 

Share this post


Link to post
Share on other sites

Your expectation seems right to me, and I confirm that the output is as you describe regardless of blend mode.

 

The blend mode only seems to affect the interaction between the Outline and other objects, not the object to which the Outline is applied.

 

Try setting the Outline to Outside, and you'll see that underlying objects are treated correctly.

 

Seems like a bug / oversight to me.


Win7 Ultimate x64   |   i5-3570K @ 3.4GHz   |   16 GB RAM   |   120 GB SSD   |   nVidia GTX 660 Ti   |   Huion 1060 Plus

How I make GIFs >>> ScreenToGIF (Windows only, Open Source, Portable, ~600kB)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×