Jump to content
markp

[Fixed] Performance degradation when using Windows Display scaling

Recommended Posts

There seems to be an issue with how Affinity Photo handles display scaling in Windows. With scaling applied, there is a severe performance degradation when using tools. I've recreated this on two computers and in both the release version and 1.5.1.47 beta using a 4k monitor under Windows 10 x64. My primary PC is an i7 2700K, 16gb RAM, & GTX 1080 gpu.

 

To most easily reproduce this:

- Set Windows Display scaling to 125%. Logging out is not needed to recreate this issue nor has any impact.

- Launch AF and open, for example, the Space Dock demo file

- With the whole canvas visible, create a new pixel layer on the top of the stack and use the paint brush to quickly scribble around the image. 

- Note the laggy, stuttering performance of the brush.

To compare:

- Close AF and set Display scaling to 100%, again logging out is not needed.

- Open the same file and repeat the test

- Brush tool is now smooth and seamless while painting.

 

Can anyone else recreate this issue? Any ideas on fixing it?

 

display_scale_video.zip

 

EDIT: Added short video clip to demonstrate - first at 125% scaling, then 100%. Note cpu usage difference. Larger display scaling values seem to further increase cpu usage.

Share this post


Link to post
Share on other sites

Glad to hear it! Thanks for looking into this issue - really appreciate the continual improvements to Affinity. Keep up the great work!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×